summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-02 07:06:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-02 07:06:10 +0000
commit070cff66067876f185624222ab4d891bbd924921 (patch)
treec29cee8bd8a9825e9836c1549ecd83256561132f /games-misc/openmsx
parentRemove unnecessary lines (diff)
downloadgentoo-2-070cff66067876f185624222ab4d891bbd924921.tar.gz
gentoo-2-070cff66067876f185624222ab4d891bbd924921.tar.bz2
gentoo-2-070cff66067876f185624222ab4d891bbd924921.zip
EAPI=5; use python-any-r1
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc/openmsx')
-rw-r--r--games-misc/openmsx/ChangeLog10
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r1.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/games-misc/openmsx/ChangeLog b/games-misc/openmsx/ChangeLog
index 69d3b296ed19..d5d1d57d7f35 100644
--- a/games-misc/openmsx/ChangeLog
+++ b/games-misc/openmsx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/openmsx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/openmsx/ChangeLog,v 1.10 2010/10/15 13:53:56 maekke Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/openmsx/ChangeLog,v 1.11 2015/01/02 07:06:10 mr_bones_ Exp $
+
+*openmsx-0.3.1-r1 (02 Jan 2015)
+
+ 02 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +openmsx-0.3.1-r1.ebuild:
+ EAPI=5; use python-any-r1
15 Oct 2010; Markus Meier <maekke@gentoo.org> openmsx-0.3.1.ebuild:
add ~arm, bug #316003
@@ -41,4 +46,3 @@
+openmsx-0.2.1.ebuild, +metadata.xml:
initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko (bug
#312993)
-
diff --git a/games-misc/openmsx/openmsx-0.3.1-r1.ebuild b/games-misc/openmsx/openmsx-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..8f20c8442e08
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/openmsx/openmsx-0.3.1-r1.ebuild,v 1.1 2015/01/02 07:06:10 mr_bones_ Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 games
+
+
+DESCRIPTION="An ambiguously named music replacement set for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/openmsx/"
+SRC_URI="http://bundles.openttdcoop.org/openmsx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-source
+
+src_compile() {
+ emake _V= bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/openttd/gm/${P}
+ doins ${P}/{*.mid,openmsx.obm} || die
+ dodoc ${P}/{changelog.txt,readme.txt} || die
+ prepgamesdirs
+}