summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-11-16 16:01:11 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-11-16 16:01:11 +0000
commit9b2fe0e92a448ae2d5ea330d8c4ad80385d85aa7 (patch)
treec0f98ca51fdf6682349ebc6eef70d75d3594cf2a /games-misc
parentNew ebuilds for obs-service-download_files. Ebuild written by me. (diff)
downloadgentoo-2-9b2fe0e92a448ae2d5ea330d8c4ad80385d85aa7.tar.gz
gentoo-2-9b2fe0e92a448ae2d5ea330d8c4ad80385d85aa7.tar.bz2
gentoo-2-9b2fe0e92a448ae2d5ea330d8c4ad80385d85aa7.zip
Migrate Gentoo Prefix modifications from overlay. EAPI, arch-specific fixes, KEYWORDS. bug 389943
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/fortune-mod/ChangeLog8
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild23
2 files changed, 22 insertions, 9 deletions
diff --git a/games-misc/fortune-mod/ChangeLog b/games-misc/fortune-mod/ChangeLog
index 5dafe4668fa4..3bfa79c0818f 100644
--- a/games-misc/fortune-mod/ChangeLog
+++ b/games-misc/fortune-mod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/fortune-mod
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.26 2010/10/08 08:34:50 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/ChangeLog,v 1.27 2011/11/16 16:01:11 darkside Exp $
+
+ 16 Nov 2011; Jeremy Olexa <darkside@gentoo.org> fortune-mod-1.99.1-r2.ebuild:
+ Migrate Gentoo Prefix modifications from overlay. EAPI, arch-specific fixes,
+ KEYWORDS. bug 389943
08 Oct 2010; Mart Raudsepp <leio@gentoo.org> fortune-mod-1.99.1-r2.ebuild:
Drop to ~mips
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
index f5fda3984aeb..f448b39b837e 100644
--- a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.9 2010/10/08 08:34:50 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.10 2011/11/16 16:01:11 darkside Exp $
-EAPI=2
+EAPI=3
inherit eutils toolchain-funcs
DESCRIPTION="The notorious fortune program"
@@ -11,7 +11,7 @@ SRC_URI="http://www.redellipse.net/code/downloads/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="offensive elibc_glibc"
DEPEND="app-text/recode"
@@ -29,20 +29,29 @@ src_prepare() {
Makefile || die "sed Makefile failed"
if ! use elibc_glibc ; then
- local reglibs="-lcompat"
+ [[ ${CHOST} == *-*bsd* ]] && local reglibs="-lcompat"
+ [[ ${CHOST} == *-darwin* ]] && local reglibs="-lc"
has_version "app-text/recode[nls]" && reglibs="${reglibs} -lintl"
sed -i \
-e "/^REGEXLIBS=/s:=.*:= ${reglibs}:" \
Makefile \
|| die "sed REGEXLIBS failed"
fi
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's:u_int:uint:g' util/strfile.h || die "sed strfile.h failed"
+ fi
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/-DBSD_REGEX/-DPOSIX_REGEX/' Makefile || die "sed Makefile failed"
+ fi
}
src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+ local myrex=
+ [[ ${CHOST} == *-interix* ]] && myrex="REGEXDEFS=-DNO_REGEX"
+ emake CC="$(tc-getCC)" $myrex || die "emake failed"
}
src_install() {
- emake prefix="${D}" install || die "emake install failed"
+ emake prefix="${ED}" install || die "emake install failed"
dodoc ChangeLog INDEX Notes Offensive README TODO cookie-files
}