summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-15 05:42:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-15 05:42:39 +0000
commita21073781bbda9024b15843584e411d7235ad23f (patch)
treeba332a25ff5642bb5104c3ec6c1f6a18b4e42d81 /games-misc
parentadding ~arm keywords to net-analyzer/metasploit rdeps (diff)
downloadgentoo-2-a21073781bbda9024b15843584e411d7235ad23f.tar.gz
gentoo-2-a21073781bbda9024b15843584e411d7235ad23f.tar.bz2
gentoo-2-a21073781bbda9024b15843584e411d7235ad23f.zip
version bump (bug #451960)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog7
-rw-r--r--games-misc/opengfx/opengfx-0.4.6.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index a62dee21217f..d95b7c01f9a2 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.28 2013/01/13 11:40:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.29 2013/01/15 05:42:39 mr_bones_ Exp $
+
+*opengfx-0.4.6.1 (15 Jan 2013)
+
+ 15 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> +opengfx-0.4.6.1.ebuild:
+ version bump (bug #451960)
13 Jan 2013; Agostino Sarubbo <ago@gentoo.org> opengfx-0.4.5.ebuild:
Stable for x86, wrt bug #449906
diff --git a/games-misc/opengfx/opengfx-0.4.6.1.ebuild b/games-misc/opengfx/opengfx-0.4.6.1.ebuild
new file mode 100644
index 000000000000..d75877e9d66c
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.4.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.6.1.ebuild,v 1.1 2013/01/15 05:42:39 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.2.4"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ sed -i \
+ -e 's:echo "gimp":echo "":g' \
+ scripts/Makefile.def || die
+}
+
+src_compile() {
+ emake bundle
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}