summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 10:30:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 10:30:08 +0000
commit779df789d3d0bd898865996e08b0b87b95cca69c (patch)
treef53bb89f6dbd66ebf2ad399db9500e33ac348849 /games-mud/crystal/crystal-0.2.2.ebuild
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.tar.gz
gentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.tar.bz2
gentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-mud/crystal/crystal-0.2.2.ebuild')
-rw-r--r--games-mud/crystal/crystal-0.2.2.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/games-mud/crystal/crystal-0.2.2.ebuild b/games-mud/crystal/crystal-0.2.2.ebuild
index 3efad49fb084..41a253dcd827 100644
--- a/games-mud/crystal/crystal-0.2.2.ebuild
+++ b/games-mud/crystal/crystal-0.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.1 2005/07/10 04:51:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.2 2008/05/01 10:30:07 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="The crystal MUD client"
HOMEPAGE="http://www.evilmagic.org/crystal/"
@@ -10,13 +10,21 @@ SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="sys-libs/zlib
sys-libs/ncurses
dev-libs/openssl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
egamesconf \
--disable-scripting || die
@@ -24,7 +32,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS README TODO
prepgamesdirs
}