summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-08 10:52:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-08 10:52:44 +0000
commit282b557df0c5787a7d9d1ca8cb08d48045cdd55c (patch)
tree57c115070de4ef99ceb37ae884e702361f895e27 /games-mud/tf
parentVersion bump, bug #165695 (diff)
downloadgentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.tar.gz
gentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.tar.bz2
gentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.zip
Version bump, bug #165517
(Portage version: 2.1.2-r8)
Diffstat (limited to 'games-mud/tf')
-rw-r--r--games-mud/tf/ChangeLog9
-rw-r--r--games-mud/tf/files/digest-tf-50_beta72
-rw-r--r--games-mud/tf/files/digest-tf-50_beta86
-rw-r--r--games-mud/tf/tf-50_beta8.ebuild58
4 files changed, 73 insertions, 2 deletions
diff --git a/games-mud/tf/ChangeLog b/games-mud/tf/ChangeLog
index d67c43790b27..6b3fd2f9e206 100644
--- a/games-mud/tf/ChangeLog
+++ b/games-mud/tf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-mud/tf
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.17 2006/10/01 23:49:32 mr_bones_ Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.18 2007/02/08 10:52:44 nyhm Exp $
+
+*tf-50_beta8 (08 Feb 2007)
+
+ 08 Feb 2007; Tristan Heaven <nyhm@gentoo.org> +tf-50_beta8.ebuild:
+ Version bump, bug #165517
01 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+files/tf-40-gcc4.patch, files/tf-40-gentoo.diff, tf-40-r2.ebuild:
diff --git a/games-mud/tf/files/digest-tf-50_beta7 b/games-mud/tf/files/digest-tf-50_beta7
index ad60f3a29b8c..f6149732cacc 100644
--- a/games-mud/tf/files/digest-tf-50_beta7
+++ b/games-mud/tf/files/digest-tf-50_beta7
@@ -1,4 +1,6 @@
MD5 e143640bfa7dd8cc1c96def5e8ec44f6 tf-50b7-help.tar.gz 174146
+RMD160 162ff9e3b8566b875f8bcabc07b30e3bef1a95eb tf-50b7-help.tar.gz 174146
+SHA256 2838e784c79f22ea9dda54ca7fbae0579554b111a80bad391902da7bb791f70c tf-50b7-help.tar.gz 174146
MD5 6652b7eda8a200d28e8184c1659137a2 tf-50b7.tar.gz 651772
RMD160 59278842ee57f101a7e3e2c8b7c282af3adbbff5 tf-50b7.tar.gz 651772
SHA256 a08ea71fe34a62798396a5ccc4e65316c262b55075f8114ea654dd8ef2ca68d7 tf-50b7.tar.gz 651772
diff --git a/games-mud/tf/files/digest-tf-50_beta8 b/games-mud/tf/files/digest-tf-50_beta8
new file mode 100644
index 000000000000..cbdc7bf4fdf7
--- /dev/null
+++ b/games-mud/tf/files/digest-tf-50_beta8
@@ -0,0 +1,6 @@
+MD5 26eb64b2f811c8143e9c08654d26d138 tf-50b8-help.tar.gz 175591
+RMD160 44bbdaa4feb21ac05e4a3a733e60ad427ebef588 tf-50b8-help.tar.gz 175591
+SHA256 d9f7c2475c6641100ff3f2e877917d4ec4660df1aaa46e0a4d510479f5d11b83 tf-50b8-help.tar.gz 175591
+MD5 3e994e791966d274f63b0e61abf2ef59 tf-50b8.tar.gz 719553
+RMD160 dd19528548c4139a1182ad7dc41bb561c17697ef tf-50b8.tar.gz 719553
+SHA256 3750a114cf947b1e3d71cecbe258cb830c39f3186c369e368d4662de9c50d989 tf-50b8.tar.gz 719553
diff --git a/games-mud/tf/tf-50_beta8.ebuild b/games-mud/tf/tf-50_beta8.ebuild
new file mode 100644
index 000000000000..929c819d274d
--- /dev/null
+++ b/games-mud/tf/tf-50_beta8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-50_beta8.ebuild,v 1.1 2007/02/08 10:52:44 nyhm Exp $
+
+inherit games
+
+MY_P="${P/_beta/b}"
+DESCRIPTION="A small, flexible, screen-oriented MUD client"
+HOMEPAGE="http://tinyfugue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug doc ipv6 ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ STRIP=: egamesconf \
+ $(use_enable ssl) \
+ $(use_enable debug core) \
+ $(use_enable ipv6 inet6) \
+ --enable-manpage || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/tf || die "dogamesbin failed"
+ newman src/tf.1.catman tf.1
+ dodoc CHANGES CREDITS README
+
+ insinto "${GAMES_DATADIR}"/${PN}-lib
+ # the application looks for this file here if /changes is called.
+ # see comments on bug #23274
+ doins CHANGES || die "doins failed"
+ insopts -m0755
+ doins tf-lib/* || die "doins failed"
+ if use doc ; then
+ dohtml -r *.html commands topics
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use ipv6 && {
+ echo
+ ewarn "You have merged TinyFugue with IPv6-support."
+ ewarn "Support for IPv6 is still being experimental."
+ ewarn "If you experience problems with connecting to hosts,"
+ ewarn "try re-merging this package with USE="-ipv6""
+ echo
+ }
+}