summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-08-03 12:33:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-08-03 12:33:39 +0000
commit73461f9b75bbb6dd348f66f8146776c07ced1903 (patch)
treecc7b679a437c240f557f003f5fcd5235ff07ce76 /games-mud/tf
parentmarked ~ppc (split out of ghc-6 to separate package) (diff)
downloadgentoo-2-73461f9b75bbb6dd348f66f8146776c07ced1903.tar.gz
gentoo-2-73461f9b75bbb6dd348f66f8146776c07ced1903.tar.bz2
gentoo-2-73461f9b75bbb6dd348f66f8146776c07ced1903.zip
Patches to support gmcp and other. Bug #361311
(Portage version: 2.1.10.10/cvs/Linux i686)
Diffstat (limited to 'games-mud/tf')
-rw-r--r--games-mud/tf/ChangeLog8
-rw-r--r--games-mud/tf/metadata.xml5
-rw-r--r--games-mud/tf/tf-50_beta8-r1.ebuild69
3 files changed, 81 insertions, 1 deletions
diff --git a/games-mud/tf/ChangeLog b/games-mud/tf/ChangeLog
index 3b3b1d022760..79a31f243646 100644
--- a/games-mud/tf/ChangeLog
+++ b/games-mud/tf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-mud/tf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.21 2011/03/28 13:22:09 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/ChangeLog,v 1.22 2011/08/03 12:33:39 tupone Exp $
+
+*tf-50_beta8-r1 (03 Aug 2011)
+
+ 03 Aug 2011; Tupone Alfredo <tupone@gentoo.org> +tf-50_beta8-r1.ebuild,
+ metadata.xml:
+ Patches to support gmcp and other. Bug #361311 by Deedra Waters
28 Mar 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> tf-50_beta8.ebuild:
x86 stable wrt bug #360701
diff --git a/games-mud/tf/metadata.xml b/games-mud/tf/metadata.xml
index d3c2cc926f0b..ea161bd9407a 100644
--- a/games-mud/tf/metadata.xml
+++ b/games-mud/tf/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
+ <use>
+ <flag name="atcp">enable ATCP support.</flag>
+ <flag name="gmcp">enable GMCP support.</flag>
+ <flag name="option102">enable telnet option 102 support.</flag>
+ </use>
</pkgmetadata>
diff --git a/games-mud/tf/tf-50_beta8-r1.ebuild b/games-mud/tf/tf-50_beta8-r1.ebuild
new file mode 100644
index 000000000000..049b08e8f03b
--- /dev/null
+++ b/games-mud/tf/tf-50_beta8-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-50_beta8-r1.ebuild,v 1.1 2011/08/03 12:33:39 tupone Exp $
+EAPI=2
+
+inherit games
+
+MY_P="${P/_beta/b}"
+DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
+HOMEPAGE="http://tinyfugue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
+ http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt ->
+ tf-allrootpatch.txt
+ http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt ->
+ tf-allsrcpatch.txt
+ doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+atcp debug doc +gmcp ipv6 +option102 ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${DISTDIR}"/tf-all*patch.txt )
+
+src_configure() {
+ STRIP=: egamesconf \
+ $(use_enable atcp) \
+ $(use_enable gmcp) \
+ $(use_enable option102) \
+ $(use_enable ssl) \
+ $(use_enable debug core) \
+ $(use_enable ipv6 inet6) \
+ --enable-manpage || die
+}
+
+src_install() {
+ dogamesbin src/tf || die "dogamesbin failed"
+ newman src/tf.1.nroffman tf.1
+ dodoc CHANGES CREDITS README
+
+ insinto "${GAMES_DATADIR}"/${PN}-lib
+ # the application looks for this file here if /changes is called.
+ # see comments on bug #23274
+ doins CHANGES || die "doins failed"
+ insopts -m0755
+ doins tf-lib/* || die "doins failed"
+ if use doc ; then
+ dohtml -r *.html commands topics
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use ipv6 && {
+ echo
+ ewarn "You have merged TinyFugue with IPv6-support."
+ ewarn "Support for IPv6 is still being experimental."
+ ewarn "If you experience problems with connecting to hosts,"
+ ewarn "try re-merging this package with USE="-ipv6""
+ echo
+ }
+}