summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-15 23:16:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-15 23:16:01 +0000
commit888a7a3ef1dd17e05c162830cc8de7ac6bfd5065 (patch)
tree5bf51a22c1d3d74e26811020671771dee8a1ed8e /games-mud/xpertmud
parentfix want_nptl logic with CHOST/CTARGET and remove nptl die when cross-compiling (diff)
downloadgentoo-2-888a7a3ef1dd17e05c162830cc8de7ac6bfd5065.tar.gz
gentoo-2-888a7a3ef1dd17e05c162830cc8de7ac6bfd5065.tar.bz2
gentoo-2-888a7a3ef1dd17e05c162830cc8de7ac6bfd5065.zip
fix dep for bug #85421
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-mud/xpertmud')
-rw-r--r--games-mud/xpertmud/ChangeLog8
-rw-r--r--games-mud/xpertmud/xpertmud-3.1_pre1.ebuild15
2 files changed, 14 insertions, 9 deletions
diff --git a/games-mud/xpertmud/ChangeLog b/games-mud/xpertmud/ChangeLog
index ef770abbb4dc..e6d7c238599e 100644
--- a/games-mud/xpertmud/ChangeLog
+++ b/games-mud/xpertmud/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/xpertmud
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.4 2004/09/03 15:11:33 dholm Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.5 2005/03/15 23:16:01 mr_bones_ Exp $
+
+ 15 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ xpertmud-3.1_pre1.ebuild:
+ fix dep for bug #85421
03 Sep 2004; David Holm <dholm@gentoo.org> xpertmud-3.1_pre1.ebuild:
Added to ~ppc.
diff --git a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
index 091ba5f0eaa3..ed1a1dbd4694 100644
--- a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
+++ b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.4 2004/09/03 15:11:33 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.5 2005/03/15 23:16:01 mr_bones_ Exp $
inherit kde
@@ -18,19 +18,20 @@ IUSE="python ruby"
DEPEND=">=sys-devel/libperl-5.6.1
python? ( >=dev-lang/python-2.2 )
- ruby? ( >=dev-lang/ruby-1.8.0 )"
+ ruby? ( >=dev-lang/ruby-1.8.0 )
+ kde-base/arts"
need-kde 3
src_compile() {
econf \
- `use_with python python` \
- `use_with ruby ruby` \
+ $(use_with python python) \
+ $(use_with ruby ruby) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make install DESTDIR=${D} || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog DESIGN NEWS README TODO
}