summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-02 07:36:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-02 07:36:59 +0000
commit52354f85c66d4b7a68ed1ca7e22c086b4209943b (patch)
tree72e9f6d4d2e097ef411ae9c2c95af8c5875d7a1d /games-puzzle/angrydd
parentmask games-mud/mcl for removal (diff)
downloadgentoo-2-52354f85c66d4b7a68ed1ca7e22c086b4209943b.tar.gz
gentoo-2-52354f85c66d4b7a68ed1ca7e22c086b4209943b.tar.bz2
gentoo-2-52354f85c66d4b7a68ed1ca7e22c086b4209943b.zip
EAPI=5; use python-single-r1
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle/angrydd')
-rw-r--r--games-puzzle/angrydd/ChangeLog8
-rw-r--r--games-puzzle/angrydd/angrydd-1.0.1.-r1ebuild51
2 files changed, 56 insertions, 3 deletions
diff --git a/games-puzzle/angrydd/ChangeLog b/games-puzzle/angrydd/ChangeLog
index 96907af8f901..53b5b015e33a 100644
--- a/games-puzzle/angrydd/ChangeLog
+++ b/games-puzzle/angrydd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/angrydd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/angrydd/ChangeLog,v 1.7 2010/09/09 16:43:17 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/angrydd/ChangeLog,v 1.8 2015/01/02 07:36:59 mr_bones_ Exp $
+
+ 02 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +angrydd-1.0.1.-r1ebuild:
+ EAPI=5; use python-single-r1
09 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org> angrydd-1.0.1.ebuild:
tidy
@@ -25,4 +28,3 @@
08 Mar 2006; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+angrydd-1.0.1.ebuild:
initial commit - ebuild submitted by Martin von Gagern via bug #119995
-
diff --git a/games-puzzle/angrydd/angrydd-1.0.1.-r1ebuild b/games-puzzle/angrydd/angrydd-1.0.1.-r1ebuild
new file mode 100644
index 000000000000..3486ac096c2c
--- /dev/null
+++ b/games-puzzle/angrydd/angrydd-1.0.1.-r1ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/angrydd/angrydd-1.0.1.-r1ebuild,v 1.1 2015/01/02 07:36:59 mr_bones_ Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="Angry, Drunken Dwarves, a falling blocks game similar to Puzzle Fighter"
+HOMEPAGE="http://www.sacredchao.net/~piman/angrydd/"
+SRC_URI="http://www.sacredchao.net/~piman/angrydd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_DATADIR}" \
+ TO="${PN}" \
+ install
+ rm -rf "${D}${GAMES_DATADIR}/games" "${D}${GAMES_DATADIR}/share" || die
+
+ python_optimize "${D}${GAMES_DATADIR}/${PN}"
+
+ dodir "${GAMES_BINDIR}"
+ dosym "${GAMES_DATADIR}/${PN}/angrydd.py" "${GAMES_BINDIR}/${PN}"
+ doman angrydd.6
+ dodoc README TODO HACKING
+
+ doicon angrydd.png
+ make_desktop_entry angrydd "Angry, Drunken Dwarves"
+
+ prepgamesdirs
+}