summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-25 03:29:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-25 03:29:32 +0000
commitd34d8a46ad11597371fef3f91c5a420fcbcecbf7 (patch)
tree07880e519d5e61ace7375fa4657f6d6b688b43f7 /games-puzzle/londonlaw/files
parentStable on x86; bug #123646 (diff)
downloadgentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.tar.gz
gentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.tar.bz2
gentoo-2-d34d8a46ad11597371fef3f91c5a420fcbcecbf7.zip
version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-puzzle/londonlaw/files')
-rw-r--r--games-puzzle/londonlaw/files/digest-londonlaw-0.2.13
-rw-r--r--games-puzzle/londonlaw/files/londonlaw-0.2.1-setup.py.patch37
2 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/londonlaw/files/digest-londonlaw-0.2.1 b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.1
new file mode 100644
index 000000000000..8b788a0c232f
--- /dev/null
+++ b/games-puzzle/londonlaw/files/digest-londonlaw-0.2.1
@@ -0,0 +1,3 @@
+MD5 8e7b630de309c75edd07974ca2574c41 londonlaw-0.2.1.tar.gz 3139208
+RMD160 20a32d4b527b220a0ae0e261c5f84dd5563db7b2 londonlaw-0.2.1.tar.gz 3139208
+SHA256 e7453f2e261315384d991ecde31de16e0024fc5f14bacd4642e1daf5d9a4eb87 londonlaw-0.2.1.tar.gz 3139208
diff --git a/games-puzzle/londonlaw/files/londonlaw-0.2.1-setup.py.patch b/games-puzzle/londonlaw/files/londonlaw-0.2.1-setup.py.patch
new file mode 100644
index 000000000000..eef8059850bf
--- /dev/null
+++ b/games-puzzle/londonlaw/files/londonlaw-0.2.1-setup.py.patch
@@ -0,0 +1,37 @@
+--- setup.py 2005-02-18 04:51:06.000000000 +0100
++++ setup.py.1 2005-02-20 22:51:31.687411720 +0100
+@@ -10,20 +10,14 @@
+ # Read off the PREFIX value, so we can tell jools where to find its
+ # data files (FIXME: is there a clean way to handle this through distutils?
+ if 'sdist' not in sys.argv and 'clean' not in sys.argv:
+- PREFIX=os.path.normpath(sys.prefix) # default
++ DATA_PREFIX="" # default
+ for arg in sys.argv:
+- index = string.find(arg, "--prefix=")
++ index = string.find(arg, "--install-data=")
+ if index > -1:
+- PREFIX = os.path.normpath(arg[(index+len("--prefix=")):])
+-
+- ROOT = "/" # default
+- for arg in sys.argv:
+- index = string.find(arg, "--root=")
+- if index > -1:
+- ROOT = os.path.normpath(arg[(index+len("--root=")):])
++ DATA_PREFIX = os.path.normpath(arg[(index+len("--install-data=")):])
+
+ config = open("londonlaw/common/config.py", "w")
+- config.write("MEDIAROOT = \"" + os.path.join(PREFIX,"share/londonlaw/guiclient") + "\"\n")
++ config.write("MEDIAROOT = \"" + os.path.join(DATA_PREFIX,"londonlaw/guiclient") + "\"\n")
+ config.close()
+
+
+@@ -37,7 +31,8 @@
+ if os.path.isfile(fullFile):
+ newFiles.append(fullFile)
+ if newFiles != []:
+- installList.append( (os.path.join('share', dirname), newFiles) )
++# installList.append( (os.path.join('share', dirname), newFiles) )
++ installList.append( (dirname, newFiles) )
+
+
+ # Get all data files by walking through the proper directory trees