summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-15 08:53:26 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-15 08:53:26 +0000
commitd6a494d2fabf1dae1fb13efc384079e926dd41c7 (patch)
tree33bae3f727512cc578f1b0ef16b146b9af856fe8 /games-puzzle/magiccube4d
parentdrop all stable keywords and clean up, due to bug 221925 (bundled libraries) (diff)
downloadgentoo-2-d6a494d2fabf1dae1fb13efc384079e926dd41c7.tar.gz
gentoo-2-d6a494d2fabf1dae1fb13efc384079e926dd41c7.tar.bz2
gentoo-2-d6a494d2fabf1dae1fb13efc384079e926dd41c7.zip
Respect LDFLAGS. Bug #335142
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/magiccube4d')
-rw-r--r--games-puzzle/magiccube4d/ChangeLog8
-rw-r--r--games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch15
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2.ebuild16
3 files changed, 29 insertions, 10 deletions
diff --git a/games-puzzle/magiccube4d/ChangeLog b/games-puzzle/magiccube4d/ChangeLog
index 0bb41537962c..e631c29bfdac 100644
--- a/games-puzzle/magiccube4d/ChangeLog
+++ b/games-puzzle/magiccube4d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/magiccube4d
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/ChangeLog,v 1.10 2007/10/22 20:30:05 angelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/ChangeLog,v 1.11 2010/10/15 08:53:26 tupone Exp $
+
+ 15 Oct 2010; Tupone Alfredo <tupone@gentoo.org> magiccube4d-2.2.ebuild,
+ +files/magiccube4d-2.2-ldflags.patch:
+ Respect LDFLAGS. Bug #335142 by flameeyes@gentoo.org
22 Oct 2007; Christoph Mende <angelos@gentoo.org>
+files/magiccube4d-2.2-64bit-ptr.patch, magiccube4d-2.2.ebuild:
diff --git a/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
new file mode 100644
index 000000000000..446eb0cc91ae
--- /dev/null
+++ b/games-puzzle/magiccube4d/files/magiccube4d-2.2-ldflags.patch
@@ -0,0 +1,15 @@
+--- Makefile.in.old 2010-10-15 10:38:48.000000000 +0200
++++ Makefile.in 2010-10-15 10:39:07.000000000 +0200
+@@ -72,10 +72,10 @@
+ $(CXX) -c $(CXXFLAGS) $<
+
+ $(TARGET): $(OBJS)
+- $(CXX) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBDIRS) $(LIBS)
+
+ $(TARGET).static: $(OBJS)
+- $(CXX) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
++ $(CXX) $(LDFLAGS) -static -o $(TARGET).static $(OBJS) $(LIBDIRS) $(LIBS)
+
+ Vec.h: vec_h.c
+ $(CC) -o vec_h vec_h.c
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
index 275ce721cd26..b77923cf9947 100644
--- a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
+++ b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.12 2007/12/12 02:11:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.13 2010/10/15 08:53:26 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -14,16 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND="x11-libs/libXaw"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}-src-${MY_PV}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-EventHandler.patch \
"${FILESDIR}/${P}"-gcc41.patch \
- "${FILESDIR}/${P}"-64bit-ptr.patch
+ "${FILESDIR}/${P}"-64bit-ptr.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "s:-Werror::" \
configure \
@@ -31,7 +32,6 @@ src_unpack() {
}
src_compile() {
- egamesconf || die
emake DFLAGS="${CFLAGS}" || die "emake failed"
}