summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-05-23 20:25:42 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-05-23 20:25:42 +0000
commit43c676d2b6d7f64d779dd962f5174eed0c62b841 (patch)
tree16849afb988054374eacadfae3f826fde7fbf52c /games-puzzle/monsterz
parentBump to 2.26.2. Make configure more portage. Update translations. (diff)
downloadgentoo-2-43c676d2b6d7f64d779dd962f5174eed0c62b841.tar.gz
gentoo-2-43c676d2b6d7f64d779dd962f5174eed0c62b841.tar.bz2
gentoo-2-43c676d2b6d7f64d779dd962f5174eed0c62b841.zip
Patch from Fedora to fix blitting error with pygame-1.8, bug #263854
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/ChangeLog12
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch32
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild40
3 files changed, 83 insertions, 1 deletions
diff --git a/games-puzzle/monsterz/ChangeLog b/games-puzzle/monsterz/ChangeLog
index adeca40fd1c7..39382ebdadcb 100644
--- a/games-puzzle/monsterz/ChangeLog
+++ b/games-puzzle/monsterz/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for games-puzzle/monsterz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.22 2009/01/11 21:34:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/ChangeLog,v 1.23 2009/05/23 20:25:42 nyhm Exp $
+
+ 23 May 2009; Tristan Heaven <nyhm@gentoo.org> +monsterz-0.7.1-r2.ebuild,
+ +files/monsterz-0.7.1-blit.patch:
+ Patch from Fedora to fix blitting error with pygame-1.8, bug #263854
+
+*monsterz-0.7.1-r2 (23 May 2009)
+
+ 23 May 2009; Tristan Heaven <nyhm@gentoo.org> +monsterz-0.7.1-r2.ebuild,
+ +files/monsterz-0.7.1-blit.patch:
+ Patch from Fedora to fix blitting error with pygame-1.8, bug #263854
11 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
monsterz-0.7.1-r1.ebuild:
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
new file mode 100644
index 000000000000..8e55b23a327c
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
@@ -0,0 +1,32 @@
+--- monsterz.py
++++ monsterz.py
+@@ -829,10 +829,10 @@
+ pass
+ else:
+ for x in range(4):
+- for y, p in enumerate(alpha[x]):
+- alpha[x][y] = p * x / 4
+- for y, p in enumerate(alpha[406 - x - 1]):
+- alpha[406 - x - 1][y] = p * x / 4
++ for y in range(len(alpha[x])):
++ alpha[x][y] = alpha[x][y] * x / 4
++ for y in range(len(alpha[406 - x - 1])):
++ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 4
+ for col in alpha:
+ l = len(col)
+ for y in range(4):
+@@ -1287,10 +1287,10 @@
+ pass
+ else:
+ for x in range(10):
+- for y, p in enumerate(alpha[x]):
+- alpha[x][y] = p * x / 12
+- for y, p in enumerate(alpha[406 - x - 1]):
+- alpha[406 - x - 1][y] = p * x / 12
++ for y in range(len(alpha[x])):
++ alpha[x][y] = alpha[x][y] * x / 12
++ for y in range(len(alpha[406 - x - 1])):
++ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 12
+ del alpha
+ scroll.unlock()
+ system.blit(scroll, (13, 437))
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..5ff7df929f21
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild,v 1.1 2009/05/23 20:25:42 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-blit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+ rm -f Makefile
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics sound || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "newgamesbin failed"
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ prepgamesdirs
+}