summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-02-15 17:57:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-02-15 17:57:52 +0000
commit9833c708df114ffd26afae6d9926e2942d0892ba (patch)
treeca1faebcd8c176d131fb979d37a73f9a7ee6bc96 /games-puzzle/pingus
parentVersion bump. (diff)
downloadgentoo-2-9833c708df114ffd26afae6d9926e2942d0892ba.tar.gz
gentoo-2-9833c708df114ffd26afae6d9926e2942d0892ba.tar.bz2
gentoo-2-9833c708df114ffd26afae6d9926e2942d0892ba.zip
add patch for working with libpng15 submitted by Lars Wendler via bug #355065
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog9
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch15
-rw-r--r--games-puzzle/pingus/pingus-0.7.3.ebuild8
3 files changed, 27 insertions, 5 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 446903cf9fa8..29fb391befe2 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.29 2010/11/19 22:40:35 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.30 2011/02/15 17:57:52 mr_bones_ Exp $
+
+ 15 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.3.ebuild,
+ +files/pingus-0.7.3-libpng15.patch:
+ add patch for working with libpng15 submitted by Lars Wendler via bug
+ #355065
19 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.3.ebuild:
use scons-utils
diff --git a/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch b/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch
new file mode 100644
index 000000000000..9260a9bbad4a
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch
@@ -0,0 +1,15 @@
+$NetBSD: patch-ac,v 1.1 2011/01/20 23:41:02 wiz Exp $
+
+Fix build with png-1.5.
+
+--- src/screenshot.cpp.orig 2007-09-30 16:07:08.000000000 +0000
++++ src/screenshot.cpp
+@@ -159,7 +159,7 @@ Screenshot::save_png(const std::string&
+ return;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem reading the file
+ fclose(fp);
diff --git a/games-puzzle/pingus/pingus-0.7.3.ebuild b/games-puzzle/pingus/pingus-0.7.3.ebuild
index ea019aa0470a..dc3c5a94e287 100644
--- a/games-puzzle/pingus/pingus-0.7.3.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.3.ebuild,v 1.5 2010/11/19 22:40:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.3.ebuild,v 1.6 2011/02/15 17:57:52 mr_bones_ Exp $
EAPI=2
inherit eutils scons-utils toolchain-funcs games
@@ -21,7 +21,9 @@ DEPEND="media-libs/libsdl[joystick,video]
dev-libs/boost"
src_prepare() {
- epatch "${FILESDIR}"/${P}-paths.patch
+ epatch \
+ "${FILESDIR}"/${P}-paths.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
sed -i \
-e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \