summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-09 02:30:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-09 02:30:02 +0000
commitd135f18ad1bea4d8760e63006d6055ae3f453d9a (patch)
treee7369e256af13bea9acd3f61c474dda680dacb96 /games-puzzle/pingus
parentRemove old wrt bug 425050 (diff)
downloadgentoo-2-d135f18ad1bea4d8760e63006d6055ae3f453d9a.tar.gz
gentoo-2-d135f18ad1bea4d8760e63006d6055ae3f453d9a.tar.bz2
gentoo-2-d135f18ad1bea4d8760e63006d6055ae3f453d9a.zip
add gcc47 patch from Markus Oehme (bug #425238)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog6
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch22
-rw-r--r--games-puzzle/pingus/pingus-0.7.6.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 8ce3b900592f..bb175da75931 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.42 2012/06/30 05:00:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.43 2012/07/09 02:30:02 mr_bones_ Exp $
+
+ 09 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.6.ebuild,
+ +files/pingus-0.7.6-gcc47.patch:
+ add gcc47 patch from Markus Oehme (bug #425238)
30 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
+files/pingus-0.7.6-noopengl.patch, pingus-0.7.6.ebuild:
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
new file mode 100644
index 000000000000..b1397da31f68
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/pingus/pingus_main.cpp.orig 2012-07-08 14:02:40.343767438 +0200
++++ src/pingus/pingus_main.cpp 2012-07-08 14:02:54.062768168 +0200
+@@ -465,7 +465,7 @@
+ void
+ PingusMain::print_greeting_message()
+ {
+- std::string greeting = "Welcome to Pingus "VERSION;
++ std::string greeting = "Welcome to Pingus " VERSION;
+ greeting += "!";
+ std::cout << greeting << std::endl;
+ for (unsigned int i = 0; i < greeting.length(); ++i)
+--- src/pingus/screens/pingus_menu.cpp.orig 2012-07-08 14:03:05.549768782 +0200
++++ src/pingus/screens/pingus_menu.cpp 2012-07-08 14:03:17.015769393 +0200
+@@ -153,7 +153,7 @@
+ gc.get_height()/2 - 280));
+
+ gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
+- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
++ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
+ "See the file AUTHORS for a complete list of contributors.\n"
+ "Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
+ "welcome to redistribute it under certain conditions; see the file COPYING for details.\n");
diff --git a/games-puzzle/pingus/pingus-0.7.6.ebuild b/games-puzzle/pingus/pingus-0.7.6.ebuild
index 9ec8604cd3d4..2dc588e14af5 100644
--- a/games-puzzle/pingus/pingus-0.7.6.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.7 2012/06/30 05:00:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.6.ebuild,v 1.8 2012/07/09 02:30:02 mr_bones_ Exp $
EAPI=2
inherit eutils flag-o-matic scons-utils toolchain-funcs games
@@ -38,7 +38,9 @@ src_prepare() {
export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
strip-flags
- epatch "${FILESDIR}"/${P}-noopengl.patch
+ epatch \
+ "${FILESDIR}"/${P}-noopengl.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
}
src_compile() {