summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-08 05:15:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-08 05:15:31 +0000
commitbfaa5aecf328d9c3b2c407af1598c6f9a9ba9880 (patch)
treedc73888f2db6979c391a458f9cfb8b7f4fe52879 /games-puzzle/xblockout/xblockout-1.1.3.ebuild
parent+games-action/xshipwars:yiff (diff)
downloadgentoo-2-bfaa5aecf328d9c3b2c407af1598c6f9a9ba9880.tar.gz
gentoo-2-bfaa5aecf328d9c3b2c407af1598c6f9a9ba9880.tar.bz2
gentoo-2-bfaa5aecf328d9c3b2c407af1598c6f9a9ba9880.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-puzzle/xblockout/xblockout-1.1.3.ebuild')
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/xblockout-1.1.3.ebuild b/games-puzzle/xblockout/xblockout-1.1.3.ebuild
new file mode 100644
index 000000000000..61f2eddfbf01
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.3.ebuild,v 1.1 2005/11/08 05:15:31 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="http://www710.univ-lyon1.fr/~exco/XBL/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ # Don't know about other archs. --slarti
+ use amd64 && filter-flags "-fweb"
+
+ sed -i \
+ -e "s:-lm:-lm -L/usr/X11R6/lib -lX11:" \
+ -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake \
+ SCOREDIR="${GAMES_STATEDIR}/${PN}" \
+ GROUP_GID=$(id -g ${GAMES_GROUP}) \
+ RESOURCEDIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ newgamesbin bl xbl || die "newgamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins Xbl.ad Xbl
+ insinto "${GAMES_STATEDIR}"/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+
+ prepgamesdirs
+}