summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-02 14:29:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-02 14:29:58 +0000
commit849cce2d0823440e92ad1088de94af3f2ab72379 (patch)
treefbc7dfc11b58e7d418c19e9422b17f959553ef66 /games-puzzle/xye
parentAdded patch to fix compilation problems with gcc-4.3 (diff)
downloadgentoo-2-849cce2d0823440e92ad1088de94af3f2ab72379.tar.gz
gentoo-2-849cce2d0823440e92ad1088de94af3f2ab72379.tar.bz2
gentoo-2-849cce2d0823440e92ad1088de94af3f2ab72379.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-puzzle/xye')
-rw-r--r--games-puzzle/xye/ChangeLog6
-rw-r--r--games-puzzle/xye/files/xye-0.8.0-gcc43.patch25
-rw-r--r--games-puzzle/xye/xye-0.8.0.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/games-puzzle/xye/ChangeLog b/games-puzzle/xye/ChangeLog
index adcded4c5ed3..495fb139c18e 100644
--- a/games-puzzle/xye/ChangeLog
+++ b/games-puzzle/xye/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/xye
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.6 2008/03/19 22:13:39 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/ChangeLog,v 1.7 2008/05/02 14:29:58 nyhm Exp $
+
+ 02 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/xye-0.8.0-gcc43.patch, xye-0.8.0.ebuild:
+ Fix building with gcc-4.3
19 Mar 2008; Tristan Heaven <nyhm@gentoo.org> xye-0.8.0.ebuild:
Add ~amd64 keyword
diff --git a/games-puzzle/xye/files/xye-0.8.0-gcc43.patch b/games-puzzle/xye/files/xye-0.8.0-gcc43.patch
new file mode 100644
index 000000000000..05659a6e5e23
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.8.0-gcc43.patch
@@ -0,0 +1,25 @@
+--- src/browser.cpp
++++ src/browser.cpp
+@@ -17,11 +17,12 @@
+
+ #include "browser.h"
+
+-#include <errno.h>
++#include <cerrno>
+
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstdio>
++#include <cstdlib>
+ #include <string>
++#include <cstring>
+
+
+
+--- src/command.cpp
++++ src/command.cpp
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include "command.h"
+
+
diff --git a/games-puzzle/xye/xye-0.8.0.ebuild b/games-puzzle/xye/xye-0.8.0.ebuild
index 0f4715e1eb40..a51a4276c0a5 100644
--- a/games-puzzle/xye/xye-0.8.0.ebuild
+++ b/games-puzzle/xye/xye-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.8.0.ebuild,v 1.2 2008/03/19 22:13:39 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xye/xye-0.8.0.ebuild,v 1.3 2008/05/02 14:29:58 nyhm Exp $
inherit eutils games
@@ -29,6 +29,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
sed -i '/^xye_LDFLAGS/d' Makefile.in || die "sed failed"
}