summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-27 15:54:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-27 15:54:42 +0000
commit31e325677dc08b881dc1b3d337e6b6c81c331c4e (patch)
tree1b74cb0f620c977e2612c9578845c24ede565568 /games-puzzle
parentVersion bump, drop old (diff)
downloadgentoo-2-31e325677dc08b881dc1b3d337e6b6c81c331c4e.tar.gz
gentoo-2-31e325677dc08b881dc1b3d337e6b6c81c331c4e.tar.bz2
gentoo-2-31e325677dc08b881dc1b3d337e6b6c81c331c4e.zip
old
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog6
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch22
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild74
3 files changed, 5 insertions, 97 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index 229fd72d2274..fd6ab3718397 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/sgt-puzzles
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.20 2015/04/26 16:00:09 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.21 2015/04/27 15:54:42 mr_bones_ Exp $
+
+ 27 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/sgt-puzzles-9306-gentoo.patch, -sgt-puzzles-9306.ebuild:
+ old
26 Apr 2015; Pacho Ramos <pacho@gentoo.org> sgt-puzzles-9861.ebuild:
x86 stable wrt bug #547136
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch
deleted file mode 100644
index 49ee58d01af0..000000000000
--- a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- mkfiles.pl
-+++ mkfiles.pl
-@@ -1117,8 +1117,8 @@
- "\n".
- &splitline("CFLAGS := -O2 -Wall -Werror -ansi -pedantic -g " .
- (join " ", map {"-I$dirpfx$_"} @srcdirs) .
-- " `\$(GTK_CONFIG) --cflags` \$(CFLAGS)")."\n".
-- "XLIBS = `\$(GTK_CONFIG) --libs`\n".
-+ " `pkg-config gtk+-2.0 --cflags` \$(CFLAGS)")."\n".
-+ "XLIBS = `pkg-config gtk+-2.0 --libs` -lm\n".
- "ULIBS =#\n".
- "INSTALL=install\n",
- "INSTALL_PROGRAM=\$(INSTALL)\n",
-@@ -1137,7 +1137,7 @@
- $objstr = &objects($p, "X.o", undef, undef);
- print &splitline($prog . ": " . $objstr), "\n";
- $libstr = &objects($p, undef, undef, "-lX");
-- print &splitline("\t\$(CC) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
-+ print &splitline("\t\$(CC) \$(LDFLAGS) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
- "\n\n";
- }
- foreach $d (&deps("X.o", undef, $dirpfx, "/")) {
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild
deleted file mode 100644
index 8e8cf06b902f..000000000000
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild,v 1.4 2012/05/04 04:45:28 jdhore Exp $
-
-EAPI=2
-inherit eutils toolchain-funcs games
-if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
- inherit subversion
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-r${PV}.tar.gz"
- S=${WORKDIR}/puzzles-r${PV}
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
-HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- dev-lang/perl
- virtual/pkgconfig
- doc? ( >=app-doc/halibut-1.0 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- ./mkfiles.pl
- sed -i \
- -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
- -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
- Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
- if use doc ; then
- halibut --text --html --info --pdf --ps puzzles.but
- fi
-}
-
-src_install() {
- dodir "${GAMES_BINDIR}"
- emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install || die
- dodoc README HACKING
-
- local file name
- for file in *.R ; do
- [[ ${file} == "nullgame.R" ]] && continue
- name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
- file=${file%.R}
- if [[ ${PV} -lt 99999999 ]] ; then
- newicon icons/${file}-48d24.png ${PN}-${file}.png || die
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
- else
- # No icons with the live version
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
- fi
- done
-
- dodoc puzzles.txt puzzles.chm
- if use doc ; then
- dohtml *.html
- doinfo puzzles.info
- dodoc puzzles.pdf puzzles.ps
- fi
-
- prepgamesdirs
-}