summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-19 20:33:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-19 20:33:13 +0000
commit46b2af9eaf163972372d6608825819df560166c6 (patch)
tree717605caa76757b3dc2f9c145e5c39db39141b04 /games-puzzle
parentBump xvid dependency as per bug #133306 thanks to Michael Mauch. (diff)
downloadgentoo-2-46b2af9eaf163972372d6608825819df560166c6.tar.gz
gentoo-2-46b2af9eaf163972372d6608825819df560166c6.tar.bz2
gentoo-2-46b2af9eaf163972372d6608825819df560166c6.zip
Fix for gcc-4.1
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/mirrormagic/ChangeLog6
-rw-r--r--games-puzzle/mirrormagic/files/mirrormagic-2.0.2-gcc41.patch10
-rw-r--r--games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild8
3 files changed, 22 insertions, 2 deletions
diff --git a/games-puzzle/mirrormagic/ChangeLog b/games-puzzle/mirrormagic/ChangeLog
index 04b99d75d255..28fe8fe3a2a0 100644
--- a/games-puzzle/mirrormagic/ChangeLog
+++ b/games-puzzle/mirrormagic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/mirrormagic
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/ChangeLog,v 1.7 2006/02/17 22:55:53 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/ChangeLog,v 1.8 2006/05/19 20:33:13 tupone Exp $
+
+ 19 May 2006; <Tupone@gentoo.org> +files/mirrormagic-2.0.2-gcc41.patch,
+ mirrormagic-2.0.2.ebuild:
+ Fix for gcc-4.1
17 Feb 2006; <Tupone@gentoo.org> mirrormagic-2.0.2.ebuild:
Modular X dependency fix
diff --git a/games-puzzle/mirrormagic/files/mirrormagic-2.0.2-gcc41.patch b/games-puzzle/mirrormagic/files/mirrormagic-2.0.2-gcc41.patch
new file mode 100644
index 000000000000..316aa3b2946a
--- /dev/null
+++ b/games-puzzle/mirrormagic/files/mirrormagic-2.0.2-gcc41.patch
@@ -0,0 +1,10 @@
+--- src/main.h.old 2006-05-19 22:24:24.000000000 +0200
++++ src/main.h 2006-05-19 22:25:57.000000000 +0200
+@@ -459,7 +459,6 @@
+ #endif
+ extern struct HiScore highscore[];
+ extern struct TapeInfo tape;
+-extern struct JoystickInfo joystick[];
+ extern struct SetupInfo setup;
+ extern struct GameInfo game;
+ extern struct LaserInfo laser;
diff --git a/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild b/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
index c3d923912c28..c78c264c62f0 100644
--- a/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
+++ b/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild,v 1.14 2006/02/17 22:55:53 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/mirrormagic/mirrormagic-2.0.2.ebuild,v 1.15 2006/05/19 20:33:13 tupone Exp $
inherit flag-o-matic games
@@ -22,6 +22,12 @@ RDEPEND="!sdl? ( || ( x11-libs/libX11 virtual/x11 ) )
DEPEND="${RDEPEND}
!sdl? ( || ( x11-libs/libXt virtual/x11 ) )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+}
+
src_compile() {
replace-flags -march=k6 -march=i586