summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-05-24 18:04:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-05-24 18:04:11 +0000
commit51c3325fdda1863549ef55f1c11944ceb03fc2bf (patch)
tree3430446b6725aa2b78da2bd40484b6adbd9eeeae /games-puzzle
parentDrop one expression from sed for last commit. Since we are not using make ins... (diff)
downloadgentoo-2-51c3325fdda1863549ef55f1c11944ceb03fc2bf.tar.gz
gentoo-2-51c3325fdda1863549ef55f1c11944ceb03fc2bf.tar.bz2
gentoo-2-51c3325fdda1863549ef55f1c11944ceb03fc2bf.zip
old
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pingus/ChangeLog7
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch15
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.3-paths.patch34
-rw-r--r--games-puzzle/pingus/pingus-0.7.3.ebuild52
-rw-r--r--games-puzzle/pingus/pingus-0.7.5.ebuild45
5 files changed, 6 insertions, 147 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 827f9fa4929d..ee1314b0882c 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/pingus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.38 2012/03/06 20:42:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.39 2012/05/24 18:04:10 mr_bones_ Exp $
+
+ 24 May 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/pingus-0.7.3-libpng15.patch, -files/pingus-0.7.3-paths.patch,
+ -pingus-0.7.3.ebuild, -pingus-0.7.5.ebuild:
+ old
06 Mar 2012; Brent Baude <ranger@gentoo.org> pingus-0.7.6.ebuild:
Marking pingus-0.7.6 ppc for bug 402603
diff --git a/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch b/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch
deleted file mode 100644
index 7919fa48dcf2..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.3-libpng15.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-ac,v 1.1 2011/01/20 23:41:02 wiz Exp $
-
-Fix build with png-1.5.
-
---- src/screenshot.cpp.orig
-+++ src/screenshot.cpp
-@@ -159,7 +159,7 @@ Screenshot::save_png(const std::string&
- return;
- }
-
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- // If we get here, we had a problem reading the file
- fclose(fp);
diff --git a/games-puzzle/pingus/files/pingus-0.7.3-paths.patch b/games-puzzle/pingus/files/pingus-0.7.3-paths.patch
deleted file mode 100644
index 00d974f92bb3..000000000000
--- a/games-puzzle/pingus/files/pingus-0.7.3-paths.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- install.sh
-+++ install.sh
-@@ -14,8 +14,8 @@
- exit 1
- fi
-
-- BINDIR="$1/bin/"
-- DATADIR="$1/share/pingus/"
-+ BINDIR="${1}GENTOO_BINDIR"
-+ DATADIR="${1}GENTOO_DATADIR"
-
- echo "Installing Pingus in: $1"
-
---- SConstruct
-+++ SConstruct
-@@ -406,7 +406,6 @@
-
- config_h = open('config.h', 'w')
- config_h.write('#define VERSION "0.7.2"\n')
-- config_h.write('#define ENABLE_BINRELOC 1\n')
- config_h.write('#define ICONV_CONST %s\n' % iconv_const)
- for (v,k) in config_h_defines:
- config_h.write('#define %s %s\n' % (v, k))
---- src/pingus_main.cpp
-+++ src/pingus_main.cpp
-@@ -583,7 +583,7 @@
- path_manager.add_path("data"); // assume game is run from source dir, without any magic
- free(exe_path);
- #else
-- path_manager.add_path("data"); // assume game is run from source dir
-+ path_manager.add_path("GENTOO_DATADIR/data");
- #endif
-
- if (!path_manager.find_path("data/core.res"))
diff --git a/games-puzzle/pingus/pingus-0.7.3.ebuild b/games-puzzle/pingus/pingus-0.7.3.ebuild
deleted file mode 100644
index dc3c5a94e287..000000000000
--- a/games-puzzle/pingus/pingus-0.7.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.3.ebuild,v 1.6 2011/02/15 17:57:52 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils scons-utils toolchain-funcs games
-
-DESCRIPTION="free Lemmings clone"
-HOMEPAGE="http://pingus.seul.org/"
-SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[joystick,video]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer
- media-libs/libpng
- dev-libs/boost"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-paths.patch \
- "${FILESDIR}"/${P}-libpng15.patch
- sed -i \
- -e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
- install.sh src/pingus_main.cpp \
- || die "sed failed"
-}
-
-src_configure() {
- scons configure \
- CXX="$(tc-getCXX)" \
- CCFLAGS="${CXXFLAGS}" \
- LINKFLAGS="${LDFLAGS}" \
- || die "scons configure failed"
-}
-
-src_compile() {
- escons || die
-}
-
-src_install() {
- ./install.sh "${D}" || die "install.sh failed"
- newicon data/images/core/worldmap/pingus_standing.png ${PN}.png
- make_desktop_entry ${PN} Pingus
- dodoc AUTHORS NEWS README TODO
- prepgamesdirs
-}
diff --git a/games-puzzle/pingus/pingus-0.7.5.ebuild b/games-puzzle/pingus/pingus-0.7.5.ebuild
deleted file mode 100644
index 883191712375..000000000000
--- a/games-puzzle/pingus/pingus-0.7.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.5.ebuild,v 1.4 2012/01/10 20:19:52 ranger Exp $
-
-EAPI=2
-inherit eutils scons-utils toolchain-funcs games
-
-DESCRIPTION="free Lemmings clone"
-HOMEPAGE="http://pingus.seul.org/"
-SRC_URI="http://pingus.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="opengl"
-
-DEPEND="media-libs/libsdl[joystick,opengl?,video]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer
- opengl? ( virtual/opengl )
- media-libs/libpng
- dev-libs/boost"
-
-src_compile() {
- escons \
- CXX="$(tc-getCXX)" \
- CCFLAGS="${CXXFLAGS}" \
- LINKFLAGS="${LDFLAGS}" \
- $(use_scons opengl with_opengl) \
- || die
-}
-
-src_install() {
- emake install-exec install-data \
- DESTDIR="${D}" \
- PREFIX="/usr" \
- DATADIR="${GAMES_DATADIR}/${PN}" \
- BINDIR="${GAMES_BINDIR}" \
- || die
- doman doc/man/pingus.6
- newicon data/images/core/worldmap/pingus_standing.png ${PN}.png
- make_desktop_entry ${PN} Pingus
- dodoc AUTHORS NEWS README TODO
- prepgamesdirs
-}