summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-18 17:14:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-18 17:14:38 +0000
commita35bd825c74054ffba7a87518fbcb972033ac950 (patch)
tree9e9447046eeab8dbe88c78f72ae8f1ca8aee08f2 /games-puzzle
parentVersion bump (diff)
downloadgentoo-2-a35bd825c74054ffba7a87518fbcb972033ac950.tar.gz
gentoo-2-a35bd825c74054ffba7a87518fbcb972033ac950.tar.bz2
gentoo-2-a35bd825c74054ffba7a87518fbcb972033ac950.zip
fix some compile warnings; tidy
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/galaxis/ChangeLog6
-rw-r--r--games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch83
-rw-r--r--games-puzzle/galaxis/galaxis-1.7.ebuild17
3 files changed, 91 insertions, 15 deletions
diff --git a/games-puzzle/galaxis/ChangeLog b/games-puzzle/galaxis/ChangeLog
index 45caa36adb7d..a0fd525af8db 100644
--- a/games-puzzle/galaxis/ChangeLog
+++ b/games-puzzle/galaxis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/galaxis
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/ChangeLog,v 1.11 2010/10/16 19:55:52 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/ChangeLog,v 1.12 2010/10/18 17:14:37 mr_bones_ Exp $
+
+ 18 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org> galaxis-1.7.ebuild,
+ +files/galaxis-1.7-gentoo.patch:
+ fix some compile warnings; tidy
16 Oct 2010; Tupone Alfredo <tupone@gentoo.org> galaxis-1.7.ebuild:
Respect LDFLAGS. Bug #334635 by flameeyes@gentoo.org
diff --git a/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch b/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch
new file mode 100644
index 000000000000..3153291d3f4f
--- /dev/null
+++ b/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch
@@ -0,0 +1,83 @@
+diff -ru galaxis-1.7.orig/Makefile galaxis-1.7/Makefile
+--- galaxis-1.7.orig/Makefile 2003-12-29 04:09:53.000000000 -0500
++++ galaxis-1.7/Makefile 2010-10-18 13:08:43.929375025 -0400
+@@ -3,9 +3,8 @@
+ VERS=$(shell sed <galaxis.spec -n -e '/Version: \(.*\)/s//\1/p')
+
+ # Flags for use with the Linux ncurses package (recommended)
+-CFLAGS = -g -DNDEBUG # -I/usr/local/include -L/usr/local/lib
++CFLAGS += -DNDEBUG # -I/usr/local/include -L/usr/local/lib
+ TERMLIB = -lncurses
+-CC = gcc
+
+ # Flags for use with stock curses
+ #CFLAGS = -DNDEBUG
+@@ -13,7 +12,7 @@
+ #CC = gcc
+
+ galaxis: galaxis.c
+- $(CC) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
+
+ galaxis.6: galaxis.xml
+ xmlto man galaxis.xml
+diff -ru galaxis-1.7.orig/galaxis.c galaxis-1.7/galaxis.c
+--- galaxis-1.7.orig/galaxis.c 2003-12-26 23:19:20.000000000 -0500
++++ galaxis-1.7/galaxis.c 2010-10-18 13:10:03.575307583 -0400
+@@ -8,6 +8,10 @@
+ #define _POSIX_SOURCE
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <time.h>
++#include <string.h>
+ #include <termios.h>
+ #include <curses.h>
+ #include <signal.h>
+@@ -29,7 +33,6 @@
+ extern long lrand48();
+ extern void srand48();
+ #define bzero(s, n) (void)memset((char *)(s), '\0', n)
+-extern char *memset();
+ /*
+ * Try this if ungetch() fails to resolve.
+ *
+@@ -167,16 +170,17 @@
+ }
+
+ /* VARARGS1 */
+-static void prompt(f, s)
++static void prompt(s)
+ /* print a message at the prompt line */
+-char *f, *s;
++char *s;
+ {
+ (void) move(PROMPTLINE, 0);
+ (void) clrtoeol();
+- (void) printw(f, s);
++ (void) printw("%s", s);
+ (void) refresh();
+ }
+
++#if 0
+ static void error(s)
+ char *s;
+ {
+@@ -188,6 +192,7 @@
+ (void) beep();
+ }
+ }
++#endif
+
+ static int rnd(n)
+ int n;
+@@ -647,7 +652,7 @@
+ }
+ }
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {
diff --git a/games-puzzle/galaxis/galaxis-1.7.ebuild b/games-puzzle/galaxis/galaxis-1.7.ebuild
index 4139635843ad..0076010768c5 100644
--- a/games-puzzle/galaxis/galaxis-1.7.ebuild
+++ b/games-puzzle/galaxis/galaxis-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/galaxis-1.7.ebuild,v 1.11 2010/10/16 19:55:52 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/galaxis/galaxis-1.7.ebuild,v 1.12 2010/10/18 17:14:37 mr_bones_ Exp $
EAPI=2
inherit games
@@ -14,20 +14,9 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
-RDEPEND=">=sys-libs/ncurses-5.3"
-DEPEND="${RDEPEND}"
+DEPEND=">=sys-libs/ncurses-5.3"
-src_prepare() {
- # Modify CFLAGS
- sed -i \
- -e '/^CC/d' \
- -e '/^CFLAGS/s:-g:$(E_CFLAGS):' \
- Makefile || die "sed Makefile failed"
-}
-
-src_compile() {
- emake E_CFLAGS="${LDFLAGS} ${CFLAGS}" || die "emake failed"
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_install() {
dogamesbin galaxis || die "dogamesbin failed"