summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-29 06:55:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-29 06:55:25 +0000
commitbb8c7bd76abac741928c4bc57a6b1e0e63f2b5dc (patch)
tree66b261a3955e6f4e2bb4c082c9f8f706eca93c1d /games-puzzle
parentBump unstable version thank Daniel Rune Jensen for report. Dropped gnome USE ... (diff)
downloadgentoo-2-bb8c7bd76abac741928c4bc57a6b1e0e63f2b5dc.tar.gz
gentoo-2-bb8c7bd76abac741928c4bc57a6b1e0e63f2b5dc.tar.bz2
gentoo-2-bb8c7bd76abac741928c4bc57a6b1e0e63f2b5dc.zip
Build with gcc-4.6 Bug #365219
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/enigma/ChangeLog8
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild5
-rw-r--r--games-puzzle/enigma/files/enigma-1.01-gcc46.patch20
3 files changed, 29 insertions, 4 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index 20c5c98648ef..a309059159d6 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/enigma
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.49 2010/07/14 21:34:42 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.50 2011/04/29 06:55:25 tupone Exp $
+
+ 29 Apr 2011; Tupone Alfredo <tupone@gentoo.org> enigma-1.01.ebuild,
+ +files/enigma-1.01-gcc46.patch:
+ Build with gcc-4.6 Bug #365219 by Diego Elio Pettenò
14 Jul 2010; Tomáš Chvátal <scarabeus@gentoo.org> enigma-1.01.ebuild:
Block dependency on the enet version.
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
index bdf7fc086cfa..9faa90292ca9 100644
--- a/games-puzzle/enigma/enigma-1.01.ebuild
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.14 2010/07/14 21:34:42 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.15 2011/04/29 06:55:25 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -31,6 +31,7 @@ src_prepare() {
"${FILESDIR}"/${P}-autotools.patch \
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc46.patch \
"${FILESDIR}"/${P}-xerces-c.patch
eautoreconf
}
diff --git a/games-puzzle/enigma/files/enigma-1.01-gcc46.patch b/games-puzzle/enigma/files/enigma-1.01-gcc46.patch
new file mode 100644
index 000000000000..18c98ecd6974
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.01-gcc46.patch
@@ -0,0 +1,20 @@
+--- lib-src/enigma-core/ecl_dict.hh.old 2011-04-29 08:41:47.649582258 +0200
++++ lib-src/enigma-core/ecl_dict.hh 2011-04-29 08:42:05.404691426 +0200
+@@ -21,6 +21,7 @@
+
+ #include "ecl_error.hh"
+ #include <utility>
++#include <cstddef>
+
+ namespace ecl
+ {
+--- lib-src/zipios++/src/directory.h.old 2011-04-29 08:40:31.063798354 +0200
++++ lib-src/zipios++/src/directory.h 2011-04-29 08:40:52.656147037 +0200
+@@ -31,6 +31,7 @@
+ #include <string>
+ #include <ctime>
+ #include <stdexcept>
++#include <cstddef>
+
+ // #include <boost.h> Contents of boost.h
+