summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-04-10 18:14:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-04-10 18:14:42 +0000
commite7b11af8ae5ad7a6a591f51f639fa2481b26c957 (patch)
treed0bd7fa0e4442d8ad0f5354d9a5bced68c47ce01 /games-puzzle
parentStable for HPPA (bug #463483). (diff)
downloadgentoo-2-e7b11af8ae5ad7a6a591f51f639fa2481b26c957.tar.gz
gentoo-2-e7b11af8ae5ad7a6a591f51f639fa2481b26c957.tar.bz2
gentoo-2-e7b11af8ae5ad7a6a591f51f639fa2481b26c957.zip
add patch from Bernard Cafarelli to fix building against libpng-1.6 (bug #465416)
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/neverball/ChangeLog10
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-libpng.patch21
-rw-r--r--games-puzzle/neverball/neverball-1.5.4.ebuild10
3 files changed, 34 insertions, 7 deletions
diff --git a/games-puzzle/neverball/ChangeLog b/games-puzzle/neverball/ChangeLog
index b333786fec9e..a5b6cbe62a48 100644
--- a/games-puzzle/neverball/ChangeLog
+++ b/games-puzzle/neverball/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/neverball
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/ChangeLog,v 1.43 2012/02/14 19:33:14 tristan Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/ChangeLog,v 1.44 2013/04/10 18:14:42 mr_bones_ Exp $
+
+ 10 Apr 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/neverball-1.5.4-libpng.patch, neverball-1.5.4.ebuild:
+ add patch from Bernard Cafarelli to fix building against libpng-1.6 (bug
+ #465416)
14 Feb 2012; Tristan Heaven <tristan@gentoo.org> neverball-1.5.4.ebuild:
Respect LINGUAS, bug #402311
@@ -200,4 +205,3 @@
initial commit of neverball. package was renamed upstream from Super Empty
Ball which was in portage as seb (which will be removed). (bug 25955) ebuild
from Brent Kelly via bug report and then modified.
-
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
new file mode 100644
index 000000000000..d7b224673186
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
@@ -0,0 +1,21 @@
+Index: neverball-1.5.4/share/base_image.c
+===================================================================
+--- neverball-1.5.4.orig/share/base_image.c
++++ neverball-1.5.4/share/base_image.c
+@@ -15,6 +15,7 @@
+ #include <png.h>
+ #include <jpeglib.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <assert.h>
+
+ #include "glext.h"
+@@ -94,7 +95,7 @@ static void *image_load_png(const char *
+ default: longjmp(png_jmpbuf(readp), -1);
+ }
+
+- if (!(bytep = png_malloc(readp, h * png_sizeof(png_bytep))))
++ if (!(bytep = png_malloc(readp, h * sizeof(png_bytep))))
+ longjmp(png_jmpbuf(readp), -1);
+
+ /* Allocate the final pixel buffer and read pixels there. */
diff --git a/games-puzzle/neverball/neverball-1.5.4.ebuild b/games-puzzle/neverball/neverball-1.5.4.ebuild
index 7e264fcdca57..1b2f752e83f8 100644
--- a/games-puzzle/neverball/neverball-1.5.4.ebuild
+++ b/games-puzzle/neverball/neverball-1.5.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/neverball-1.5.4.ebuild,v 1.6 2012/02/14 19:33:14 tristan Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/neverball/neverball-1.5.4.ebuild,v 1.7 2013/04/10 18:14:42 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -17,7 +17,7 @@ RESTRICT="test"
RDEPEND="media-libs/libsdl[audio,joystick,opengl,video]
media-libs/sdl-ttf
- media-libs/libpng
+ media-libs/libpng:0
virtual/jpeg
media-libs/libvorbis
virtual/opengl
@@ -39,7 +39,9 @@ src_prepare() {
-e "/^MAPC_TARG/s/mapc/${PN}-mapc/" \
Makefile \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-libpng.patch
}
src_compile() {