summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-04 20:32:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-04 20:32:36 +0000
commitec6c4561230a613c1ecb23c8281e04b892e429e0 (patch)
tree8916b4c06b44312aed58add30551f128547636a0 /games-puzzle
parentVersion bump as requested in bug #220020. (diff)
downloadgentoo-2-ec6c4561230a613c1ecb23c8281e04b892e429e0.tar.gz
gentoo-2-ec6c4561230a613c1ecb23c8281e04b892e429e0.tar.bz2
gentoo-2-ec6c4561230a613c1ecb23c8281e04b892e429e0.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gnudoku/ChangeLog6
-rw-r--r--games-puzzle/gnudoku/files/gnudoku-0.93-gcc43.patch20
-rw-r--r--games-puzzle/gnudoku/gnudoku-0.93.ebuild13
3 files changed, 37 insertions, 2 deletions
diff --git a/games-puzzle/gnudoku/ChangeLog b/games-puzzle/gnudoku/ChangeLog
index 03d31ab76094..5ebc55908aad 100644
--- a/games-puzzle/gnudoku/ChangeLog
+++ b/games-puzzle/gnudoku/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/gnudoku
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnudoku/ChangeLog,v 1.9 2008/01/18 02:53:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnudoku/ChangeLog,v 1.10 2008/05/04 20:32:35 nyhm Exp $
+
+ 04 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/gnudoku-0.93-gcc43.patch, gnudoku-0.93.ebuild:
+ Fix building with gcc-4.3
18 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org> gnudoku-0.93.ebuild:
add dev-util/pkgconfig dep (bug #206397)
diff --git a/games-puzzle/gnudoku/files/gnudoku-0.93-gcc43.patch b/games-puzzle/gnudoku/files/gnudoku-0.93-gcc43.patch
new file mode 100644
index 000000000000..69dd08c3e8b0
--- /dev/null
+++ b/games-puzzle/gnudoku/files/gnudoku-0.93-gcc43.patch
@@ -0,0 +1,20 @@
+--- GNUDoku.C
++++ GNUDoku.C
+@@ -25,6 +25,7 @@
+ #include <cstdlib>
+ #include <cstdio>
+ #include <ctime>
++#include <cstring>
+
+ #include <vector>
+ #include <cassert>
+--- sudoku.C
++++ sudoku.C
+@@ -10,6 +10,7 @@
+ #include <cstdio>
+ #include <cstdlib>
+ #include <ctime>
++#include <cstring>
+
+ #include <map>
+ namespace sudoku
diff --git a/games-puzzle/gnudoku/gnudoku-0.93.ebuild b/games-puzzle/gnudoku/gnudoku-0.93.ebuild
index a68cd6c730c9..66d59e1e90ea 100644
--- a/games-puzzle/gnudoku/gnudoku-0.93.ebuild
+++ b/games-puzzle/gnudoku/gnudoku-0.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnudoku/gnudoku-0.93.ebuild,v 1.5 2008/01/18 02:53:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnudoku/gnudoku-0.93.ebuild,v 1.6 2008/05/04 20:32:35 nyhm Exp $
inherit eutils games
@@ -22,9 +22,20 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i \
+ -e "s:\$(CXX):\$(CXX) ${CXXFLAGS} ${LDFLAGS}:" \
+ Makefile \
+ || die "sed failed"
+}
+
src_install() {
dogamesbin GNUDoku || die "dogamesbin failed"
newicon GNUDoku.png ${PN}.png
make_desktop_entry ${MY_PN} ${MY_PN}
+ dodoc ALGORITHM Changelog README TODO
prepgamesdirs
}