summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 19:19:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 19:19:36 +0000
commitf34a5a97902218ac0c5d3a13a7f4152082a453d5 (patch)
tree4c6db9f1c08ed5507a618fab43323ce83c91d4d8 /games-puzzle
parent[sys-cluster/slurm] Fix install in case no torque use flag set (diff)
downloadgentoo-2-f34a5a97902218ac0c5d3a13a7f4152082a453d5.tar.gz
gentoo-2-f34a5a97902218ac0c5d3a13a7f4152082a453d5.tar.bz2
gentoo-2-f34a5a97902218ac0c5d3a13a7f4152082a453d5.zip
version bump; turn off pointless assembly which also works around bug #411185
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gfifteen/ChangeLog7
-rw-r--r--games-puzzle/gfifteen/gfifteen-1.0.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/games-puzzle/gfifteen/ChangeLog b/games-puzzle/gfifteen/ChangeLog
index 92eefe3cd68d..974a5ecb198b 100644
--- a/games-puzzle/gfifteen/ChangeLog
+++ b/games-puzzle/gfifteen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/gfifteen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gfifteen/ChangeLog,v 1.4 2012/04/12 19:18:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gfifteen/ChangeLog,v 1.5 2012/04/18 19:19:36 mr_bones_ Exp $
+
+*gfifteen-1.0.2 (18 Apr 2012)
+
+ 18 Apr 2012; Michael Sterrett <mr_bones_@gentoo.org> +gfifteen-1.0.2.ebuild:
+ version bump; turn off pointless assembly which also works around bug #411185
*gfifteen-1.0.1 (12 Apr 2012)
diff --git a/games-puzzle/gfifteen/gfifteen-1.0.2.ebuild b/games-puzzle/gfifteen/gfifteen-1.0.2.ebuild
new file mode 100644
index 000000000000..2f9f6e746c7d
--- /dev/null
+++ b/games-puzzle/gfifteen/gfifteen-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gfifteen/gfifteen-1.0.2.ebuild,v 1.1 2012/04/18 19:19:36 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="graphical implementation of the sliding puzzle game fifteen"
+HOMEPAGE="https://frigidcode.com/code/gfifteen/"
+SRC_URI="https://frigidcode.com/code/gfifteen/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-assembly || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog || die
+ doicon ${PN}.svg
+ domenu gfifteen.desktop
+ prepgamesdirs
+}