summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-25 09:35:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-25 09:35:19 +0000
commit3d5f9906d20e39945cb4eabe018dffe9ae0ae59c (patch)
treed5f6b95dd25e1f4a6ae591a52de12518bc1286b3 /games-roguelike/tome
parenterror check sed; tidy (Manifest recommit) (diff)
downloadgentoo-2-3d5f9906d20e39945cb4eabe018dffe9ae0ae59c.tar.gz
gentoo-2-3d5f9906d20e39945cb4eabe018dffe9ae0ae59c.tar.bz2
gentoo-2-3d5f9906d20e39945cb4eabe018dffe9ae0ae59c.zip
Restore the patching of the source (bug #53636)
Diffstat (limited to 'games-roguelike/tome')
-rw-r--r--games-roguelike/tome/ChangeLog6
-rw-r--r--games-roguelike/tome/files/2.2.7-gentoo-paths.patch31
-rw-r--r--games-roguelike/tome/tome-2.2.7.ebuild16
3 files changed, 47 insertions, 6 deletions
diff --git a/games-roguelike/tome/ChangeLog b/games-roguelike/tome/ChangeLog
index 75fb225caa22..6a475f307826 100644
--- a/games-roguelike/tome/ChangeLog
+++ b/games-roguelike/tome/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/tome
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.11 2004/06/24 23:14:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.12 2004/06/25 09:35:19 mr_bones_ Exp $
+
+ 25 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/2.2.7-gentoo-paths.patch, tome-2.2.7.ebuild:
+ Restore the patching of the source (bug #53636)
03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> tome-2.2.3.ebuild,
tome-2.2.5.ebuild:
diff --git a/games-roguelike/tome/files/2.2.7-gentoo-paths.patch b/games-roguelike/tome/files/2.2.7-gentoo-paths.patch
new file mode 100644
index 000000000000..d171a1cf540f
--- /dev/null
+++ b/games-roguelike/tome/files/2.2.7-gentoo-paths.patch
@@ -0,0 +1,31 @@
+diff -rU 1 tome-225-src.orig/src/files.c tome-225-src/src/files.c
+--- tome-225-src.orig/src/files.c 2004-01-14 11:17:02.423263360 -0500
++++ tome-225-src/src/files.c 2004-01-14 11:17:50.074019344 -0500
+@@ -5670,3 +5670,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5748,3 +5748,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -5846,3 +5846,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+@@ -6296,3 +6296,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
+diff -rU 1 tome-225-src.orig/src/init2.c tome-225-src/src/init2.c
+--- tome-225-src.orig/src/init2.c 2004-01-14 11:17:02.473255760 -0500
++++ tome-225-src/src/init2.c 2004-01-14 11:17:58.286770816 -0500
+@@ -6686,3 +6686,3 @@
+ /* Build the filename */
+- path_build(buf, 1024, ANGBAND_DIR_APEX, "scores.raw");
++ sprintf(buf, "GENTOO_DIR/tome-scores.raw");
+
diff --git a/games-roguelike/tome/tome-2.2.7.ebuild b/games-roguelike/tome/tome-2.2.7.ebuild
index c159775e4ff2..59e2b5e4c394 100644
--- a/games-roguelike/tome/tome-2.2.7.ebuild
+++ b/games-roguelike/tome/tome-2.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.7.ebuild,v 1.2 2004/06/24 23:14:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.7.ebuild,v 1.3 2004/06/25 09:35:19 mr_bones_ Exp $
inherit eutils games
@@ -14,17 +14,23 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
IUSE=""
-DEPEND="virtual/glibc
+RDEPEND="virtual/glibc
dev-lang/lua
>=sys-libs/ncurses-5
virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
-S=${WORKDIR}/tome-${MY_PV}-src
+S="${WORKDIR}/tome-${MY_PV}-src"
src_unpack() {
unpack ${A}
- cp "${S}/src/makefile.std" "${S}/src/makefile" \
- || die "cp failed"
+ cd "${S}/src"
+ mv makefile.std makefile
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ sed -i \
+ -e "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c \
+ || die "sed failed"
find "${S}" -name .cvsignore -exec rm -f \{\} \;
}