summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-12-02 20:23:16 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-12-02 20:23:16 +0000
commit13a2e0a74e78a260fed3b86f49a99dfd8fab73cb (patch)
tree2848405081e5fc8b1bfdbe33cf8e1759ace2b1b9 /games-roguelike
parentStable for ppc64, wrt bug #444836 (diff)
downloadgentoo-2-13a2e0a74e78a260fed3b86f49a99dfd8fab73cb.tar.gz
gentoo-2-13a2e0a74e78a260fed3b86f49a99dfd8fab73cb.tar.bz2
gentoo-2-13a2e0a74e78a260fed3b86f49a99dfd8fab73cb.zip
Version bump to 3.4.1 Bug #442430
(Portage version: 2.1.11.33/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/ChangeLog7
-rw-r--r--games-roguelike/angband/angband-3.4.1.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/games-roguelike/angband/ChangeLog b/games-roguelike/angband/ChangeLog
index ccd36ebfcd99..d18ca54d6203 100644
--- a/games-roguelike/angband/ChangeLog
+++ b/games-roguelike/angband/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/angband
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.45 2012/05/02 21:06:17 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.46 2012/12/02 20:23:16 tupone Exp $
+
+*angband-3.4.1 (02 Dec 2012)
+
+ 02 Dec 2012; Tupone Alfredo <tupone@gentoo.org> +angband-3.4.1.ebuild:
+ Version bump to 3.4.1 Bug #442430 by Ivan S. Titov
02 May 2012; Jeff Horelick <jdhore@gentoo.org> angband-3.2.0.ebuild,
angband-3.3.2.ebuild:
diff --git a/games-roguelike/angband/angband-3.4.1.ebuild b/games-roguelike/angband/angband-3.4.1.ebuild
new file mode 100644
index 000000000000..fe79cd31320e
--- /dev/null
+++ b/games-roguelike/angband/angband-3.4.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/angband-3.4.1.ebuild,v 1.1 2012/12/02 20:23:16 tupone Exp $
+
+EAPI=4
+inherit eutils versionator games
+
+MAJOR_PV=$(get_version_component_range 1-2)
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
+HOMEPAGE="http://rephial.org/"
+SRC_URI="http://rephial.org/downloads/${MAJOR_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses sdl +sound X"
+
+RDEPEND="X? ( x11-libs/libX11 )
+ !ncurses? ( !X? ( !sdl? ( sys-libs/ncurses ) ) )
+ ncurses? ( sys-libs/ncurses )
+ sdl? ( media-libs/libsdl[video,X]
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ sound? ( media-libs/sdl-mixer
+ media-libs/libsdl[audio] ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( changes.txt faq.txt readme.txt thanks.txt )
+
+src_prepare() {
+ sed -i \
+ -e "/^.SILENT/d" \
+ mk/buildsys.mk.in \
+ || dir "sed failed"
+}
+
+src_configure() {
+ local myconf
+
+ if use sdl; then
+ myconf="$(use_enable sound sdl-mixer)"
+ else
+ myconf="--disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --bindir="${GAMES_BINDIR}" \
+ --with-private-dirs \
+ $(use_enable X x11) \
+ $(use_enable sdl) \
+ $(use_enable ncurses curses) \
+ $(use !sdl && use !ncurses && use !X && \
+ echo --enable-curses) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ # Edit files are now system config files in Angband, but
+ # users will be hidden from applying updates by default
+ echo "CONFIG_PROTECT_MASK=\"${GAMES_SYSCONFDIR}/${PN}/edit/\"" \
+ > "${T}"/99${PN}
+ doenvd "${T}"/99${PN} || die
+
+ # Create desktop entries if required.
+ ICON_LOC="${GAMES_DATADIR}/${PN}/xtra/icon/att-32.png"
+ if use X; then
+ make_desktop_entry "angband -mx11" "Angband (X11)" "${ICON_LOC}"
+ fi
+
+ if use sdl; then
+ make_desktop_entry "angband -msdl" "Angband (SDL)" "${ICON_LOC}"
+ fi
+
+ use ncurses || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/graf"
+ use sound || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/sound"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ elog "Angband now uses private savefiles instead of system-wide ones"
+ elog "This version of Angband is not compatible with the save files"
+ elog "of previous versions"
+ echo
+
+ games_pkg_postinst
+}