summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-08-25 23:12:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-08-25 23:12:46 +0000
commit8013c5ea51b7a7e6dfdc3de9211df6cb056b3c40 (patch)
tree7f1faf1ecbd61fa946e57d50e9a80ed2c5705b8d /games-roguelike
parentamd64 stable, bug 190238 (diff)
downloadgentoo-2-8013c5ea51b7a7e6dfdc3de9211df6cb056b3c40.tar.gz
gentoo-2-8013c5ea51b7a7e6dfdc3de9211df6cb056b3c40.tar.bz2
gentoo-2-8013c5ea51b7a7e6dfdc3de9211df6cb056b3c40.zip
Version bump to 1.10.0 bug #179705
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog10
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.10.0.ebuild62
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.10.03
3 files changed, 73 insertions, 2 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 80de12f2d56c..286364b07a67 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.17 2006/07/10 01:07:42 mr_bones_ Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.18 2007/08/25 23:12:45 tupone Exp $
+
+*crossfire-client-1.10.0 (25 Aug 2007)
+
+ 25 Aug 2007; Tupone Alfredo <tupone@gentoo.org>
+ +crossfire-client-1.10.0.ebuild:
+ Version bump to 1.10.0 bug #179705 by Epicanis
10 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
crossfire-client-1.9.1.ebuild:
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.10.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.10.0.ebuild
new file mode 100644
index 000000000000..b126bb67a4a3
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.10.0.ebuild,v 1.1 2007/08/25 23:12:45 tupone Exp $
+
+inherit games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa gtk oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ gtk? ( >=x11-libs/gtk+-2
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image ) )
+ virtual/glut
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -r 's:TH (g?)cfclient:TH \1cfclient 6:' \
+ {gtk,x11}/*cfclient.man \
+ || die "sed failed"
+}
+
+src_compile() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf="--disable-dependency-tracking"
+
+ if use gtk ; then
+ use sdl || myconf="${myconf} --disable-sdl"
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+ if ! use alsa ; then
+ myconf="${myconf} --disable-alsa9 --disable-alsa"
+ fi
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf} || die
+ # bug 139785
+ if use alsa || use oss ; then
+ emake -j1 -C sound-src || die "sound building failed"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.10.0 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.10.0
new file mode 100644
index 000000000000..b186fd96cc63
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.10.0
@@ -0,0 +1,3 @@
+MD5 883296ef199cbf47334d52d8b5d61886 crossfire-client-1.10.0.tar.gz 744838
+RMD160 3987b9ac463bd41ff0b65cc3b167dca5badae392 crossfire-client-1.10.0.tar.gz 744838
+SHA256 5ca392d661c1ce8419109fabd48cc6ebedab14223e69aa9ab6f63d0a401d2593 crossfire-client-1.10.0.tar.gz 744838