summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-18 19:14:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-18 19:14:15 +0000
commita3556806e36f9487e3feded69f6af83e558d2e7a (patch)
treeebdc1effb48c8d8815a115e37ad6411b52f6612f /games-roguelike
parentEAPI=5 (diff)
downloadgentoo-2-a3556806e36f9487e3feded69f6af83e558d2e7a.tar.gz
gentoo-2-a3556806e36f9487e3feded69f6af83e558d2e7a.tar.bz2
gentoo-2-a3556806e36f9487e3feded69f6af83e558d2e7a.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/ivan/ChangeLog8
-rw-r--r--games-roguelike/ivan/ivan-0.50.ebuild22
2 files changed, 17 insertions, 13 deletions
diff --git a/games-roguelike/ivan/ChangeLog b/games-roguelike/ivan/ChangeLog
index 80c5478a24fc..82c93e0c447f 100644
--- a/games-roguelike/ivan/ChangeLog
+++ b/games-roguelike/ivan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-roguelike/ivan
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.12 2008/06/17 01:47:44 mr_bones_ Exp $
+# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.13 2015/02/18 19:14:15 mr_bones_ Exp $
+
+ 18 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> ivan-0.50.ebuild:
+ EAPI=5
17 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+files/ivan-0.50-gcc43.patch, ivan-0.50.ebuild:
@@ -38,4 +41,3 @@
08 Aug 2003; Michael Sterrett <msterret@gentoo.org> ivan-0.430.ebuild:
initial commit. ebuild supplied by Rob Cakebread (modified) bug 26225
-
diff --git a/games-roguelike/ivan/ivan-0.50.ebuild b/games-roguelike/ivan/ivan-0.50.ebuild
index 4aee0305e9a0..a52679ac99d8 100644
--- a/games-roguelike/ivan/ivan-0.50.ebuild
+++ b/games-roguelike/ivan/ivan-0.50.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.10 2009/09/24 23:03:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.11 2015/02/18 19:14:15 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils flag-o-matic games
DESCRIPTION="Rogue-like game with SDL graphics"
@@ -14,12 +14,15 @@ SLOT="0"
KEYWORDS="~ppc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl"
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
-PATCHES=(
- "${FILESDIR}"/${P}-gcc41.patch
- "${FILESDIR}"/${P}-install.patch
- "${FILESDIR}"/${P}-gcc43.patch )
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
src_configure() {
replace-flags -O? -O0 #bug #113627
@@ -27,8 +30,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog LICENSING NEWS README
+ default
keepdir "${GAMES_STATEDIR}/ivan/Bones"
prepgamesdirs
fperms g+w "${GAMES_STATEDIR}/ivan/Bones"