summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-03 23:56:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-03 23:56:21 +0000
commita4964b9cb20e15d8fd7ea1f03bf75321b854cc6a (patch)
tree9a0cf37092cee7bb09692a9578a29765cdb68d33 /games-roguelike
parentFix current sparc stable for gcc-4.4 too, so it doesn't hold up any longer (diff)
downloadgentoo-2-a4964b9cb20e15d8fd7ea1f03bf75321b854cc6a.tar.gz
gentoo-2-a4964b9cb20e15d8fd7ea1f03bf75321b854cc6a.tar.bz2
gentoo-2-a4964b9cb20e15d8fd7ea1f03bf75321b854cc6a.zip
initial commit - ebuild and patch submitted by Sergey Zasenko via bug #256768 with additional help from Anton Romanov
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/powder/ChangeLog11
-rw-r--r--games-roguelike/powder/files/powder-113-make.patch107
-rw-r--r--games-roguelike/powder/metadata.xml5
-rw-r--r--games-roguelike/powder/powder-113.ebuild32
4 files changed, 155 insertions, 0 deletions
diff --git a/games-roguelike/powder/ChangeLog b/games-roguelike/powder/ChangeLog
new file mode 100644
index 000000000000..d5b4b6040594
--- /dev/null
+++ b/games-roguelike/powder/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-roguelike/powder
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/ChangeLog,v 1.1 2010/05/03 23:56:21 mr_bones_ Exp $
+
+*powder-113 (03 May 2010)
+
+ 03 May 2010; Michael Sterrett <mr_bones_@gentoo.org> +powder-113.ebuild,
+ +files/powder-113-make.patch, +metadata.xml:
+ initial commit - ebuild and patch submitted by Sergey Zasenko via bug
+ #256768 with additional help from Anton Romanov
+
diff --git a/games-roguelike/powder/files/powder-113-make.patch b/games-roguelike/powder/files/powder-113-make.patch
new file mode 100644
index 000000000000..9f6dda709d23
--- /dev/null
+++ b/games-roguelike/powder/files/powder-113-make.patch
@@ -0,0 +1,107 @@
+--- powder110_src/make/makerules.origin 2009-01-29 00:32:32.141421840 +0200
++++ powder110_src/make/makerules 2009-01-29 00:27:37.128428046 +0200
+@@ -1,11 +1,11 @@
+ .cpp.o:
+- g++ -O3 -I . -DLINUX -c $< -o $@ $(CXXFLAGS)
++ $(CXX) -I . -DLINUX -c $< -o $@ $(CXXFLAGS)
+
+ all: $(TARGET)
+
+ $(TARGET): $(OFILES)
+- g++ -O3 -o $(TARGET) $(OFILES) $(CXXFLAGS)
++ $(CXX) -o $(TARGET) $(OFILES) $(CXXFLAGS)
+
+ clean:
+- rm -f *.o
+- rm -f $(TARGET)
++ $(RM) *.o
++ $(RM) $(TARGET)
+--- powder110_src/make/makerules.LINUX.origin 2009-01-28 21:59:57.499759608 +0200
++++ powder110_src/make/makerules.LINUX 2009-01-29 00:27:34.747275321 +0200
+@@ -1,5 +1,5 @@
+ .cpp.o:
+- g++ -O3 -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $< -o $@ $(CXXFLAGS)
++ $(CXX) -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $< -o $@ $(CXXFLAGS)
+
+ all: $(TARGET)
+
+@@ -8,10 +8,10 @@
+ # http://www.trilithium.com/johan/2005/06/static-libstdc/
+ # and is to try and ensure we end up with a static link
+ # of stdc++.
+- rm -f libstdc++.a
++ $(RM) libstdc++.a
+ ln -s `g++ -print-file-name=libstdc++.a`
+- g++ -O3 -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++ $(CXX) -static-libgcc -L. -o $(TARGET) $(OFILES) `sdl-config --libs` $(CXXFLAGS)
+
+ clean:
+- rm -f *.o
+- rm -f $(TARGET)
++ $(RM) *.o
++ $(RM) $(TARGET)
+--- powder110_src/port/linux/Makefile.orig 2008-01-14 04:28:15.000000000 +0200
++++ powder110_src/port/linux/Makefile 2009-01-29 02:19:52.018078431 +0200
+@@ -38,19 +38,54 @@
+ ../../gfx/all_bitmaps.o \
+ ../../rooms/allrooms.o
+
+-include ../../make/makerules.LINUX
++PREMAKE_TRG = ../../support/map2c/map2c \
++ ../../support/tile2c/tile2c \
++ ../../support/bmp2c/bmp2c \
++ ../../support/encyclopedia2c/encyclopedia2c \
++ ../../support/enummaker/enummaker\
++ ../../support/txt2c/txt2c
+
+-clean:
+- cd ../.. ; rm -f *.o
+- cd ../../gfx ; rm -f *.o
+- rm -f *.o
+- cd ../sdl ; rm -f *.o
+- rm -f $(TARGET)
++all: $(TARGET)
++
++
++$(PREMAKE_TRG):
++ $(MAKE) -C `dirname $@`
+
+-premake:
++premake: $(PREMAKE_TRG)
+ cd ../../rooms ; ./buildrooms.bash
+ cd ../../gfx ; ./rebuild.sh
+ cd ../.. ; support/enummaker/enummaker source.txt
+ cd ../.. ; support/txt2c/txt2c LICENSE.TXT license.cpp
+ cd ../.. ; support/txt2c/txt2c CREDITS.TXT credits.cpp
+ cd ../.. ; support/encyclopedia2c/encyclopedia2c encyclopedia.txt
++
++$(OFILES): premake
++ $(CXX) -DLINUX -I ../../port/sdl `sdl-config --cflags` -c $(patsubst %.o,%.cpp,$@) -o $@ $(CXXFLAGS)
++
++$(TARGET): $(OFILES)
++ $(CXX) -o $@ $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++
++$(TARGET)-static: $(OFILES)
++ # This extra step is from:
++ # http://www.trilithium.com/johan/2005/06/static-libstdc/
++ # and is to try and ensure we end up with a static link
++ # of stdc++.
++ $(RM) libstdc++.a
++ ln -s `g++ -print-file-name=libstdc++.a`
++ $(CXX) -static-libgcc -L. -o $@ $(OFILES) `sdl-config --libs` $(CXXFLAGS)
++
++clean:
++ $(RM) *.o $(TARGET) libstdc++.a
++ cd ../../; $(RM) credits.cpp encyclopedia.cpp encyclopedia.h glbdef.cpp glbdef.h license.cpp
++ cd ../../gfx; $(RM)
++ cd ../../gfx; $(RM) icon_sdl.bmp.c slug_and_blood.bmp.c slug_and_blood_hires.bmp.c classic/*.c adambolt/*.c nethack/*.c ascii/*.c akoimeexx/*.c
++ cd ../../rooms/; $(RM) *.cpp allrooms.h allrooms.o
++ $(RM)
++ $(RM) ../../*.o
++ $(RM) ../../gfx/*.o
++ $(RM) ../sdl/*.o
++ @for trgt in $$( echo "$(PREMAKE_TRG)" | tr -s ' ' '\n' ); do \
++ $(MAKE) clean -C `dirname $$trgt` ; \
++ done;
++
++.PHONY: all clean premake
diff --git a/games-roguelike/powder/metadata.xml b/games-roguelike/powder/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-roguelike/powder/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-roguelike/powder/powder-113.ebuild b/games-roguelike/powder/powder-113.ebuild
new file mode 100644
index 000000000000..7e126ef50a75
--- /dev/null
+++ b/games-roguelike/powder/powder-113.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/powder/powder-113.ebuild,v 1.1 2010/05/03 23:56:21 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic eutils games
+
+MY_P=${P/-/}_src
+
+DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play."
+HOMEPAGE="http://www.zincland.com/powder/"
+SRC_URI="http://www.zincland.com/powder/release/${MY_P}.tar.gz"
+
+LICENSE="CCPL-Sampling-Plus-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ append-cxxflags -DCHANGE_WORK_DIRECTORY
+ emake -j1 -C port/linux || die
+}
+
+src_install() {
+ dogamesbin port/linux/${PN} || die
+ dodoc README.TXT CREDITS.TXT
+ prepgamesdirs
+}