summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-02 04:45:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-02 04:45:24 +0000
commitc2b90807898b20e947fec5f2fd4e5274c3d3c71c (patch)
tree505264fcf79e588e1ebf5fb81b169f0f2b00adf4 /games-roguelike
parentFix bugs #240230, #241280, and #243954. (diff)
downloadgentoo-2-c2b90807898b20e947fec5f2fd4e5274c3d3c71c.tar.gz
gentoo-2-c2b90807898b20e947fec5f2fd4e5274c3d3c71c.tar.bz2
gentoo-2-c2b90807898b20e947fec5f2fd4e5274c3d3c71c.zip
EAPI=2; fix data directory permissions (bug #270064)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/zangband/ChangeLog8
-rw-r--r--games-roguelike/zangband/zangband-2.7.4c.ebuild13
2 files changed, 12 insertions, 9 deletions
diff --git a/games-roguelike/zangband/ChangeLog b/games-roguelike/zangband/ChangeLog
index 11d0de587a86..eb1de69c910e 100644
--- a/games-roguelike/zangband/ChangeLog
+++ b/games-roguelike/zangband/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/zangband
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/ChangeLog,v 1.14 2008/03/13 17:39:52 wolf31o2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/ChangeLog,v 1.15 2009/08/02 04:45:24 mr_bones_ Exp $
+
+ 02 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ zangband-2.7.4c.ebuild:
+ EAPI=2; fix data directory permissions (bug #270064)
13 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
zangband-2.7.4b.ebuild:
diff --git a/games-roguelike/zangband/zangband-2.7.4c.ebuild b/games-roguelike/zangband/zangband-2.7.4c.ebuild
index 495a82757db6..85a2060e99c1 100644
--- a/games-roguelike/zangband/zangband-2.7.4c.ebuild
+++ b/games-roguelike/zangband/zangband-2.7.4c.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/zangband-2.7.4c.ebuild,v 1.5 2008/02/02 21:39:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/zangband/zangband-2.7.4c.ebuild,v 1.6 2009/08/02 04:45:24 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="An enhanced version of the Roguelike game Angband"
@@ -25,14 +26,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
-src_compile() {
+src_configure() {
egamesconf \
--datadir="${GAMES_DATADIR_BASE}" \
--with-setgid="${GAMES_GROUP}" \
--without-gtk \
- $(use_with tk tcltk) \
- || die
- emake || die "emake failed"
+ $(use_with tk tcltk)
}
src_install() {
@@ -54,5 +53,5 @@ src_install() {
prepgamesdirs
# All users in the games group need write permissions to
# some important dirs
- fperms -R g+w "${GAMES_DATADIR}"/zangband/lib/{apex,save,user}
+ fperms -R g+w "${GAMES_DATADIR}"/zangband/lib/{apex,data,save,user}
}