summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-03 00:12:49 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-03 00:12:49 +0000
commit3032aef5e0a1fb2d5cdca167893893c79b5e5e96 (patch)
tree230bce05b22f1a6c0ae37f500c0e52fb66e818e0 /games-rpg/adonthell
parentVersion bump, drop old. (diff)
downloadgentoo-2-3032aef5e0a1fb2d5cdca167893893c79b5e5e96.tar.gz
gentoo-2-3032aef5e0a1fb2d5cdca167893893c79b5e5e96.tar.bz2
gentoo-2-3032aef5e0a1fb2d5cdca167893893c79b5e5e96.zip
migrate to python-single-r1
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/ChangeLog9
-rw-r--r--games-rpg/adonthell/adonthell-0.3.5-r1.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index c14b7b7c852c..fbce45da7153 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/adonthell
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.23 2012/04/13 19:22:44 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.24 2013/02/03 00:12:49 hasufell Exp $
+
+*adonthell-0.3.5-r1 (03 Feb 2013)
+
+ 03 Feb 2013; Julian Ospald <hasufell@gentoo.org> +adonthell-0.3.5-r1.ebuild:
+ migrate to python-single-r1
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> adonthell-0.3.5.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..f4f6634ff296
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.5-r1.ebuild,v 1.1 2013/02/03 00:12:49 hasufell Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit autotools eutils python-single-r1 games
+
+DESCRIPTION="roleplaying game engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc nls"
+
+RDEPEND="media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ media-libs/libsdl[X,video,audio]
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libvorbis
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen
+ )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${PV/a/}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-configure.in.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ sed -i \
+ -e "/AC_PATH_PROGS/s:python:${EPYTHON}:" \
+ configure.in || die "sed failed"
+ rm -f ac{local,include}.m4
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-py-debug \
+ $(use_enable nls) \
+ $(use_enable doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir "${GAMES_DATADIR}"/${PN}/games
+ dodoc AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS README
+ prepgamesdirs
+}