summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-02-21 08:27:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-02-21 08:27:05 +0000
commit607ca3e9b6f01c7d67f5e7a3b4216f513ef331d5 (patch)
tree07eacd2f6f28ee20ebf152bedaed2ad17eef968b /games-rpg/egoboo
parentAdding net-libs/enet dependency (diff)
downloadgentoo-2-607ca3e9b6f01c7d67f5e7a3b4216f513ef331d5.tar.gz
gentoo-2-607ca3e9b6f01c7d67f5e7a3b4216f513ef331d5.tar.bz2
gentoo-2-607ca3e9b6f01c7d67f5e7a3b4216f513ef331d5.zip
Using right compiler. Moving 2.22 to 2.2.2 (1st pass)
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'games-rpg/egoboo')
-rw-r--r--games-rpg/egoboo/ChangeLog8
-rw-r--r--games-rpg/egoboo/egoboo-2.2.2-r1.ebuild60
-rw-r--r--games-rpg/egoboo/egoboo-2.7.4.ebuild6
3 files changed, 70 insertions, 4 deletions
diff --git a/games-rpg/egoboo/ChangeLog b/games-rpg/egoboo/ChangeLog
index d9233d2c3951..f520f495ac46 100644
--- a/games-rpg/egoboo/ChangeLog
+++ b/games-rpg/egoboo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/egoboo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/ChangeLog,v 1.17 2010/02/21 08:06:29 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/ChangeLog,v 1.18 2010/02/21 08:27:05 tupone Exp $
+
+*egoboo-2.2.2-r1 (21 Feb 2010)
+
+ 21 Feb 2010; Tupone Alfredo <tupone@gentoo.org> +egoboo-2.2.2-r1.ebuild,
+ egoboo-2.7.4.ebuild:
+ Using right compiler. Moving 2.22 to 2.2.2 (1st pass)
21 Feb 2010; Tupone Alfredo <tupone@gentoo.org> egoboo-2.7.4.ebuild:
Adding net-libs/enet dependency
diff --git a/games-rpg/egoboo/egoboo-2.2.2-r1.ebuild b/games-rpg/egoboo/egoboo-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..2e6af0965401
--- /dev/null
+++ b/games-rpg/egoboo/egoboo-2.2.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.2.2-r1.ebuild,v 1.1 2010/02/21 08:27:05 tupone Exp $
+
+inherit eutils flag-o-matic toolchain-funcs games
+
+PVOLD="2.22"
+
+DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
+HOMEPAGE="http://egoboo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/ego${PVOLD/./}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ use !amd64 && replace-cpu-flags 'athlon*' pentium4 i686
+
+ unpack ${A}
+ cd "${S}"
+
+ # Fix endianess using SDL
+ # amd64 patch must be applied after ${PV}-endian.patch
+ # this addresses bug #104271
+ epatch \
+ "${FILESDIR}"/${PVOLD}-endian.patch \
+ "${FILESDIR}"/${PVOLD}-amd64.patch
+}
+
+src_compile() {
+ cd code
+ emake clean || die "make clean failed"
+ emake FLAGS="-D_LINUX ${CFLAGS}" CC="$(tc-getCC)" egoboo || die "emake failed"
+}
+
+src_install () {
+ games_make_wrapper ${PN} ./${PN} "${GAMES_DATADIR}/${PN}"
+ dodoc egoboo.txt
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r basicdat/ import/ modules/ players/ text/ \
+ code/egoboo controls.txt setup.txt \
+ || die "doins failed"
+ # FIXME: this is stupid. should be patched to run out of GAMES_BINDIR
+ fperms 750 "${GAMES_DATADIR}/${PN}/${PN}"
+ newicon basicdat/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Egoboo /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+ # ugly, but the game needs write here.
+ cd "${D}${GAMES_DATADIR}/${PN}"
+ chmod -R g+w setup.txt basicdat players import
+}
diff --git a/games-rpg/egoboo/egoboo-2.7.4.ebuild b/games-rpg/egoboo/egoboo-2.7.4.ebuild
index 79d3ca1c0835..1da0696784d7 100644
--- a/games-rpg/egoboo/egoboo-2.7.4.ebuild
+++ b/games-rpg/egoboo/egoboo-2.7.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.7.4.ebuild,v 1.2 2010/02/21 08:06:29 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.7.4.ebuild,v 1.3 2010/02/21 08:27:05 tupone Exp $
EAPI=2
-inherit eutils games
+inherit eutils toolchain-funcs games
DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
HOMEPAGE="http://egoboo.sourceforge.net/"
@@ -32,7 +32,7 @@ src_prepare() {
}
src_compile() {
- emake -C game -f Makefile.unix
+ emake -C game -f Makefile.unix CC="$(tc-getCC)" || die "emake failed"
}
src_install() {