summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-21 22:26:53 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-21 22:26:53 +0000
commit5f795e8e1f4b8849aff2d6008ad6f9d13394c577 (patch)
tree3d29ecd8a3bcc4582d8b5d05d412d794ee6eed10 /games-rpg/nwn-data
parentAdd modular x dependencies, general ebuild cleanup. (diff)
downloadgentoo-2-5f795e8e1f4b8849aff2d6008ad6f9d13394c577.tar.gz
gentoo-2-5f795e8e1f4b8849aff2d6008ad6f9d13394c577.tar.bz2
gentoo-2-5f795e8e1f4b8849aff2d6008ad6f9d13394c577.zip
Added .metadata directory for possible use in the nwn ebuild.
(Portage version: 2.1_pre1)
Diffstat (limited to 'games-rpg/nwn-data')
-rw-r--r--games-rpg/nwn-data/ChangeLog5
-rw-r--r--games-rpg/nwn-data/nwn-data-1.29.ebuild24
2 files changed, 27 insertions, 2 deletions
diff --git a/games-rpg/nwn-data/ChangeLog b/games-rpg/nwn-data/ChangeLog
index 65d986647c84..aec2ecffbbe1 100644
--- a/games-rpg/nwn-data/ChangeLog
+++ b/games-rpg/nwn-data/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/nwn-data
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/ChangeLog,v 1.6 2005/11/02 22:53:22 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/ChangeLog,v 1.7 2005/12/21 22:26:53 wolf31o2 Exp $
+
+ 21 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org> nwn-data-1.29.ebuild:
+ Added .metadata directory for possible use in the nwn ebuild.
02 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> nwn-data-1.29.ebuild:
Added license checking.
diff --git a/games-rpg/nwn-data/nwn-data-1.29.ebuild b/games-rpg/nwn-data/nwn-data-1.29.ebuild
index 68ec38cb7cdd..3be3c811538e 100644
--- a/games-rpg/nwn-data/nwn-data-1.29.ebuild
+++ b/games-rpg/nwn-data/nwn-data-1.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/nwn-data-1.29.ebuild,v 1.7 2005/11/02 22:53:22 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-data/nwn-data-1.29.ebuild,v 1.8 2005/12/21 22:26:53 wolf31o2 Exp $
inherit eutils games
@@ -60,6 +60,25 @@ pkg_setup() {
src_unpack() {
mkdir "${S}"
cd "${S}"
+ # We create this .metadata directory so we can keep track of what we have
+ # installed without needing to keep all of these multiple USE flags in all
+ # of the ebuilds.
+ mkdir -p "${S}"/.metadata || die "Creating .metadata"
+ if use linguas_de
+ then
+ touch .metadata/linguas_de || die "touching de"
+ elif use linguas_es
+ then
+ touch .metadata/linguas_es || die "touching es"
+ elif use linguas_fr
+ then
+ touch .metadata/linguas_fr || die "touching fr"
+ elif use linguas_it
+ then
+ touch .metadata/linguas_it || die "touching it"
+ else
+ touch .metadata/linguas_en || die "touching en"
+ fi
unpack nwclient129.tar.gz
cd "${WORKDIR}"
use nowin && unpack nwresources129.tar.gz
@@ -78,6 +97,7 @@ src_unpack() {
unzip -o ${CDROM_ROOT}/Language_update.zip
unzip -o ${CDROM_ROOT}/Data_Linux.zip
rm -f data/patch.bif patch.key
+ touch .metadata/sou || die "touching sou"
fi
if use hou
then
@@ -91,6 +111,7 @@ src_unpack() {
unzip -o ${CDROM_ROOT}/Language_data.zip
unzip -o ${CDROM_ROOT}/Language_update.zip
fi
+ touch .metadata/hou || die "touching hou"
sed -i -e '\:^./nwmain .*:i \
if [[ -f ./nwmouse.so ]]; then \
export XCURSOR_PATH="$(pwd)" \
@@ -108,6 +129,7 @@ src_install() {
rm -rf "${S}"/dialog.tlk "${S}"/dialog.TLK "${S}"/dmclient "${S}"/nwmain \
"${S}"/nwserver "${S}"/nwm/* "${S}"/SDL-1.2.5 "${S}"/fixinstall
mv "${S}"/* "${Ddir}"
+ mv "${S}"/.metadata "${Ddir}"
keepdir ${dir}/servervault
keepdir ${dir}/scripttemplates
keepdir ${dir}/saves