summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2010-01-23 17:04:39 +0000
committerDenis Dupeyron <calchan@gentoo.org>2010-01-23 17:04:39 +0000
commit3f746c9e06e6eb58a88c7da4cc880b88d3f3fc9c (patch)
treef4a5f824c7433317c5bb72c9f2701e2b823ec53f /games-rpg/sacred-gold
parentAdd ~arm (diff)
downloadgentoo-2-3f746c9e06e6eb58a88c7da4cc880b88d3f3fc9c.tar.gz
gentoo-2-3f746c9e06e6eb58a88c7da4cc880b88d3f3fc9c.tar.bz2
gentoo-2-3f746c9e06e6eb58a88c7da4cc880b88d3f3fc9c.zip
Version bump (bug #267993).
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'games-rpg/sacred-gold')
-rw-r--r--games-rpg/sacred-gold/ChangeLog10
-rw-r--r--games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/games-rpg/sacred-gold/ChangeLog b/games-rpg/sacred-gold/ChangeLog
index f21e512ee5f3..e07fda78fcd5 100644
--- a/games-rpg/sacred-gold/ChangeLog
+++ b/games-rpg/sacred-gold/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/sacred-gold
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/ChangeLog,v 1.2 2009/12/15 14:56:03 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/ChangeLog,v 1.3 2010/01/23 17:04:39 calchan Exp $
+
+*sacred-gold-1.0.01 (23 Jan 2010)
+
+ 23 Jan 2010; Denis Dupeyron <calchan@gentoo.org>
+ +sacred-gold-1.0.01.ebuild:
+ Version bump (bug #267993).
15 Dec 2009; Peter Volkov <pva@gentoo.org> metadata.xml:
metadata.xml: added required herd tag.
diff --git a/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
new file mode 100644
index 000000000000..c55f52446d1b
--- /dev/null
+++ b/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/sacred-gold/sacred-gold-1.0.01.ebuild,v 1.1 2010/01/23 17:04:39 calchan Exp $
+
+inherit versionator eutils games
+
+PV_MAJOR=$(get_version_component_range 1-2)
+MY_P=sacred-${PV_MAJOR}-${PV}
+
+DESCRIPTION="Action role-playing game"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=sacred"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/sacred/${MY_P}-x86.run"
+
+LICENSE="as-is GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="virtual/opengl
+ x86? ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds .data/bin/Linux/x86/sacred
+ ln -sfn "${CDROM_ROOT}"/.data cd
+ unpack ./cd/data/data.tar.gz
+ rm -f cd
+ cp -f "${CDROM_ROOT}"/.data/bin/Linux/x86/sacred* . || die
+ cp -f "${CDROM_ROOT}"/README* . || die
+ cp -f "${CDROM_ROOT}"/manual.pdf . || die
+
+ mkdir -p patch
+ cd patch
+ unpack_makeself ${MY_P}-x86.run
+ bin/Linux/x86/loki_patch patch.dat "${S}" || die "loki_patch failed"
+ cd "${S}"
+ rm -rf patch
+
+ mv lib/lib{1,2}/* lib
+ rmdir lib/lib{1,2}
+}
+
+src_install() {
+ dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ mv * "${D}/${dir}" || die
+
+ games_make_wrapper ${PN} ./sacred "${dir}" "${dir}"/lib
+ newicon "${CDROM_ROOT}"/.data/icon.xpm ${PN}.xpm || die
+ make_desktop_entry ${PN} "Sacred - Gold" ${PN}
+
+ prepgamesdirs
+}