summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-23 19:55:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-23 19:55:14 +0000
commit177a5cb15e2227e5b22abcb181fd1e9b2ee9fec4 (patch)
tree599558980c5eb4e16adf5622a8460983ab37fc2b /games-rpg
parentAdded gcc3 patch. Closes #29317 (diff)
downloadgentoo-2-177a5cb15e2227e5b22abcb181fd1e9b2ee9fec4.tar.gz
gentoo-2-177a5cb15e2227e5b22abcb181fd1e9b2ee9fec4.tar.bz2
gentoo-2-177a5cb15e2227e5b22abcb181fd1e9b2ee9fec4.zip
Added gcc3 patch. Closes #29317
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/vegastrike/ChangeLog5
-rw-r--r--games-rpg/vegastrike/Manifest7
-rw-r--r--games-rpg/vegastrike/files/vegastrike-0.3.1-gcc3.patch59
-rw-r--r--games-rpg/vegastrike/vegastrike-0.3.1.ebuild5
4 files changed, 70 insertions, 6 deletions
diff --git a/games-rpg/vegastrike/ChangeLog b/games-rpg/vegastrike/ChangeLog
index b960a3156f8d..d60c67dc6566 100644
--- a/games-rpg/vegastrike/ChangeLog
+++ b/games-rpg/vegastrike/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-rpg/vegastrike
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/ChangeLog,v 1.2 2003/09/10 16:09:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/ChangeLog,v 1.3 2003/09/23 19:55:07 mholzer Exp $
+
+ 24 Sep 2003; Martin Holzer <mholzer@gentoo.org> vegastrike-0.3.1.ebuild:
+ Added gcc3 patch. Closes #29317
*vegastrike-0.3.1 (21 Jun 2003)
diff --git a/games-rpg/vegastrike/Manifest b/games-rpg/vegastrike/Manifest
index 0db178488140..f2bc934413a9 100644
--- a/games-rpg/vegastrike/Manifest
+++ b/games-rpg/vegastrike/Manifest
@@ -1,6 +1,5 @@
-MD5 d1811801a868447e6bbfa1799416b637 ChangeLog 1023
-MD5 1bcf9969aa0bbb8f20c16c0484b8acea vegastrike-0.3.1.ebuild 2186
-MD5 35cd4d479a540bacbd915614849fd21a vegastrike-0.4.1.ebuild 2139
+MD5 9a12488fdb86d20257501ac2d10558f9 ChangeLog 1134
+MD5 5a134dcb0afcd3da8a53ad0b5ff214f7 vegastrike-0.3.1.ebuild 2264
MD5 2e620174666c33d1a873ea9f3f68286e files/0.3.1-vsinstall.patch 975
MD5 b7121086183c9741c97fe59559fd9177 files/digest-vegastrike-0.3.1 156
-MD5 daa5fd2fbd52c26d75342dce9367308d files/digest-vegastrike-0.4.1 78
+MD5 6106850a49aab787ec7af37878f3518a files/vegastrike-0.3.1-gcc3.patch 3437
diff --git a/games-rpg/vegastrike/files/vegastrike-0.3.1-gcc3.patch b/games-rpg/vegastrike/files/vegastrike-0.3.1-gcc3.patch
new file mode 100644
index 000000000000..55adc9baa35a
--- /dev/null
+++ b/games-rpg/vegastrike/files/vegastrike-0.3.1-gcc3.patch
@@ -0,0 +1,59 @@
+diff -ur vegastrike/src/boost129/boost/python/operators.hpp vegastrike-gentoo/src/boost129/boost/python/operators.hpp
+--- vegastrike/src/boost129/boost/python/operators.hpp 2003-09-22 18:21:04.000000000 +1200
++++ vegastrike-gentoo/src/boost129/boost/python/operators.hpp 2003-09-22 19:15:13.000000000 +1200
+@@ -175,7 +175,7 @@
+ { \
+ template <class L, class R> \
+ inline detail::operator_<detail::op_##id,L,R> \
+- operator##op(L const&, R const&) \
++ operator op(L const&, R const&) \
+ { \
+ return detail::operator_<detail::op_##id,L,R>(); \
+ } \
+@@ -262,7 +262,7 @@
+ { \
+ template <class R> \
+ inline detail::operator_<detail::op_##id,self_t,R> \
+- operator##op(self_t const&, R const&) \
++ operator op(self_t const&, R const&) \
+ { \
+ return detail::operator_<detail::op_##id,self_t,R>(); \
+ } \
+diff -ur vegastrike/src/gui/text_area.h vegastrike-gentoo/src/gui/text_area.h
+--- vegastrike/src/gui/text_area.h 2003-09-22 18:21:01.000000000 +1200
++++ vegastrike-gentoo/src/gui/text_area.h 2003-09-22 19:13:11.000000000 +1200
+@@ -49,20 +49,20 @@
+ #define DIR_TEXT "textures/gui/"
+
+ // These defines are used by the image loader
+-#define TEXT_AREA_00 DIR_TEXT ## "button_down.png"
+-#define TEXT_AREA_01 DIR_TEXT ## "button_up.png"
+-#define TEXT_AREA_02 DIR_TEXT ## "corner_top_left.png"
+-#define TEXT_AREA_03 DIR_TEXT ## "corner_top_right.png"
+-#define TEXT_AREA_04 DIR_TEXT ## "corner_bottom_left.png"
+-#define TEXT_AREA_05 DIR_TEXT ## "corner_bottom_right.png"
+-#define TEXT_AREA_06 DIR_TEXT ## "highlight_button_up.png"
+-#define TEXT_AREA_07 DIR_TEXT ## "highlight_button_down.png"
+-#define TEXT_AREA_08 DIR_TEXT ## "horizontal.png"
+-#define TEXT_AREA_09 DIR_TEXT ## "left_side.png"
+-#define TEXT_AREA_10 DIR_TEXT ## "right_side.png"
+-#define TEXT_AREA_11 DIR_TEXT ## "scrollbar.png"
+-#define TEXT_AREA_12 DIR_TEXT ## "highlight_scrollbar.png"
+-#define TEXT_AREA_13 DIR_TEXT ## "horizontal_end.png"
++#define TEXT_AREA_00 DIR_TEXT "button_down.png"
++#define TEXT_AREA_01 DIR_TEXT "button_up.png"
++#define TEXT_AREA_02 DIR_TEXT "corner_top_left.png"
++#define TEXT_AREA_03 DIR_TEXT "corner_top_right.png"
++#define TEXT_AREA_04 DIR_TEXT "corner_bottom_left.png"
++#define TEXT_AREA_05 DIR_TEXT "corner_bottom_right.png"
++#define TEXT_AREA_06 DIR_TEXT "highlight_button_up.png"
++#define TEXT_AREA_07 DIR_TEXT "highlight_button_down.png"
++#define TEXT_AREA_08 DIR_TEXT "horizontal.png"
++#define TEXT_AREA_09 DIR_TEXT "left_side.png"
++#define TEXT_AREA_10 DIR_TEXT "right_side.png"
++#define TEXT_AREA_11 DIR_TEXT "scrollbar.png"
++#define TEXT_AREA_12 DIR_TEXT "highlight_scrollbar.png"
++#define TEXT_AREA_13 DIR_TEXT "horizontal_end.png"
+
+ // These defines are used by the class functions to locate the texture in the array (above)
+ #define IMG_BUTTON_DOWN 0
diff --git a/games-rpg/vegastrike/vegastrike-0.3.1.ebuild b/games-rpg/vegastrike/vegastrike-0.3.1.ebuild
index 16983a952de9..6ae09b240af1 100644
--- a/games-rpg/vegastrike/vegastrike-0.3.1.ebuild
+++ b/games-rpg/vegastrike/vegastrike-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/vegastrike-0.3.1.ebuild,v 1.1 2003/09/10 06:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/vegastrike-0.3.1.ebuild,v 1.2 2003/09/23 19:55:07 mholzer Exp $
inherit games eutils flag-o-matic
@@ -34,6 +34,9 @@ src_unpack() {
rpm2targz ${DISTDIR}/${PN}-data-${DATA_VER}.noarch.rpm || die "data rpm2targz failed"
tar -zxf ${PN}-data-${DATA_VER}.noarch.tar.gz || die "src tar failed"
+ cd ${WORKDIR}
+ #Fixes gcc3 issue
+ epatch ${FILESDIR}/${P}-gcc3.patch || die
cd ${S}
autoconf || die