summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-05-08 21:31:32 +0000
committerDavid Holm <dholm@gentoo.org>2004-05-08 21:31:32 +0000
commita609de83bd48aa6524a9452345a43846fd8f8ccc (patch)
treedc710a9428369feb18ce633078d763c64122848c /games-rpg
parentAdded gnuconfig support for mips. (Manifest recommit) (diff)
downloadgentoo-2-a609de83bd48aa6524a9452345a43846fd8f8ccc.tar.gz
gentoo-2-a609de83bd48aa6524a9452345a43846fd8f8ccc.tar.bz2
gentoo-2-a609de83bd48aa6524a9452345a43846fd8f8ccc.zip
Added patch to fix bug in endianess.h, keyworded ~ppc
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/vegastrike/ChangeLog8
-rw-r--r--games-rpg/vegastrike/files/0.4.1-endianess.patch20
-rw-r--r--games-rpg/vegastrike/vegastrike-0.4.1.ebuild5
3 files changed, 29 insertions, 4 deletions
diff --git a/games-rpg/vegastrike/ChangeLog b/games-rpg/vegastrike/ChangeLog
index 7e4db5911404..f996bf758775 100644
--- a/games-rpg/vegastrike/ChangeLog
+++ b/games-rpg/vegastrike/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/vegastrike
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/ChangeLog,v 1.5 2003/11/23 00:08:36 mholzer Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/ChangeLog,v 1.6 2004/05/08 21:31:32 dholm Exp $
+
+ 08 May 2004; David Holm <dholm@gentoo.org> +files/0.4.1-endianess.patch,
+ vegastrike-0.4.1.ebuild:
+ Added patch to fix compilation bug. Added to ~ppc.
23 Nov 2003; Martin Holzer <mholzer@gentoo.org> vegastrike-0.3.1.ebuild,
vegastrike-0.4.1.ebuild:
diff --git a/games-rpg/vegastrike/files/0.4.1-endianess.patch b/games-rpg/vegastrike/files/0.4.1-endianess.patch
new file mode 100644
index 000000000000..a1dc641cc067
--- /dev/null
+++ b/games-rpg/vegastrike/files/0.4.1-endianess.patch
@@ -0,0 +1,20 @@
+--- vegastrike/src/endianness.h.orig 2004-05-08 20:41:15.000000000 +0200
++++ vegastrike/src/endianness.h 2004-05-08 21:45:29.000000000 +0200
+@@ -42,7 +42,7 @@
+ (((uint32_t)(x) >> 8) & 0x0000FF00) | \
+ ((uint32_t)(x) >> 24))
+ # define le16_to_cpu(x) (((x&0xFF)<<8) | ((unsigned short)(x)>>8))
+- # define le64_to_cpu(x) (DONTUSE__NXSwapBigDoubleToLittle(x))
++ # define le64_to_cpu(x) (DONTUSE__NXSwapBigDoubleToLittleEndian(x))
+ # else
+ # define le32_to_cpu(x) (x)
+ # define le16_to_cpu(x) (x)
+@@ -53,7 +53,7 @@
+ # include <byteswap.h>
+ # define le32_to_cpu(x) (bswap_32(x))
+ # define le16_to_cpu(x) (bswap_16(x))
+- # define le64_to_cpu(x) (DONTUSE__NXSwapBigDoubleToLittle(x))
++ # define le64_to_cpu(x) (DONTUSE__NXSwapBigDoubleToLittleEndian(x))
+ #else
+ # define le32_to_cpu(x) (x)
+ # define le16_to_cpu(x) (x)
diff --git a/games-rpg/vegastrike/vegastrike-0.4.1.ebuild b/games-rpg/vegastrike/vegastrike-0.4.1.ebuild
index 029b8e86ee3e..dbbc75f3166b 100644
--- a/games-rpg/vegastrike/vegastrike-0.4.1.ebuild
+++ b/games-rpg/vegastrike/vegastrike-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/vegastrike-0.4.1.ebuild,v 1.9 2004/04/26 20:08:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/vegastrike/vegastrike-0.4.1.ebuild,v 1.10 2004/05/08 21:31:32 dholm Exp $
inherit games eutils flag-o-matic
@@ -11,7 +11,7 @@ RESTRICT="nomirror"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~ppc"
IUSE="sdl"
RDEPEND="virtual/glu
@@ -39,6 +39,7 @@ src_unpack() {
# save space :)
rm ${tar}
done
+ epatch ${FILESDIR}/${PV}-endianess.patch
# Clean up data dir
find data -name CVS -type d -exec rm -rf '{}' \; >&/dev/null