summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-09-05 08:02:15 +0000
committerRoy Marples <uberlord@gentoo.org>2006-09-05 08:02:15 +0000
commitbd84fbfe8f1f59154c96f9693fb4a5a30a481c6f (patch)
tree5fd5d9921c53f9ecb3674b6deb1b241826b64789 /games-rpg
parentReally restore lost file. :/ (diff)
downloadgentoo-2-bd84fbfe8f1f59154c96f9693fb4a5a30a481c6f.tar.gz
gentoo-2-bd84fbfe8f1f59154c96f9693fb4a5a30a481c6f.tar.bz2
gentoo-2-bd84fbfe8f1f59154c96f9693fb4a5a30a481c6f.zip
NEW_WEATHER is broken, don't use it.
Install shaders. (Portage version: 2.1.1_rc1-r3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/eternal-lands/ChangeLog9
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.3.2-r1.ebuild137
-rw-r--r--games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2-r16
3 files changed, 151 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands/ChangeLog b/games-rpg/eternal-lands/ChangeLog
index 0b99c02258b8..c1829d6dd693 100644
--- a/games-rpg/eternal-lands/ChangeLog
+++ b/games-rpg/eternal-lands/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/eternal-lands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.25 2006/09/03 17:00:40 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/ChangeLog,v 1.26 2006/09/05 08:02:15 uberlord Exp $
+
+*eternal-lands-1.3.2-r1 (05 Sep 2006)
+
+ 05 Sep 2006; Roy Marples <uberlord@gentoo.org>
+ +eternal-lands-1.3.2-r1.ebuild:
+ NEW_WEATHER is broken, don't use it.
+ Install shaders.
*eternal-lands-1.3.2 (03 Sep 2006)
diff --git a/games-rpg/eternal-lands/eternal-lands-1.3.2-r1.ebuild b/games-rpg/eternal-lands/eternal-lands-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..520265fedf25
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.3.2-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.3.2-r1.ebuild,v 1.1 2006/09/05 08:02:15 uberlord Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+S="${WORKDIR}/elc"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_${MY_PV}.tar.bz2
+ mirror://gentoo/eternal-lands.png"
+
+# NOTE: Sometimes you'll have to roll your own elc tarball from their CVS
+# tree as they don't always release one.
+# If they do then use this in SRC_URI instead
+# ftp://ftp.berlios.de/pub/elc/elc_${MY_PV}.tgz
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext )
+ virtual/x11 )
+ virtual/opengl
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.5
+ ~media-libs/openal-0.0.8
+ media-libs/freealut
+ media-libs/libvorbis
+ >=dev-libs/libxml2-2.6.7
+ || ( =media-libs/cal3d-0.10.0 =media-libs/cal3d-0.11.0 )
+ >=media-libs/libpng-1.2.8
+ ~games-rpg/${PN}-data-${PV}"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-apps/findutils
+ doc? ( >=app-doc/doxygen-1.3.8
+ >=media-gfx/graphviz-1.10 )"
+
+src_unpack() {
+ OPTIONS="OPTIONS=-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="konqueror"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Remove CVS entries
+ find . -type d -name CVS -exec rm -rf {} \; 2>/dev/null
+
+ # Create updated files with correct perms and allow dir creation
+ epatch "${FILESDIR}/${PN}-1.3.0-update-createdir.patch"
+
+ # Clean compile with all OpenAL versions
+ epatch "${FILESDIR}/${PN}-1.3.0-openal.patch"
+
+ # Allow shaders to actually work
+ epatch "${FILESDIR}/${P}-shader.patch"
+
+ # Build for amd64
+ use amd64 && OPTIONS="${OPTIONS} -DX86_64"
+
+ # Use these experimental options - I like them :)
+ OPTIONS="${OPTIONS} -DCUSTOM_LOOK"
+
+ # Requires a patch to use correct dir
+ OPTIONS="${OPTIONS} -DUSE_SHADER"
+
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ sed \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O -ggdb -pipe@CFLAGS=${CFLAGS} @g"\
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O -ggdb -pipe@CXXFLAGS=${CXXFLAGS} @g"\
+ -e "s@OPTIONS=@${OPTIONS} @g" \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux > Makefile \
+ || die "sed failed"
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Framebuffer support is way buggy - remove it
+ sed -i -e '/OPTIONS=/ s/-DUSE_FRAMEBUFFER//' Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ newgamesbin el.x86.linux.bin el || die "newgamesbin failed"
+ doicon "${DISTDIR}/eternal-lands.png"
+ make_desktop_entry el "Eternal Lands"
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r *.ini *.txt commands.lst shader || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "Auto Update is now enabled in Eternal Lands"
+ ewarn "If an update occurs then the client will suddenly exit"
+ einfo "Updates only happen when the game first loads"
+ einfo "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
diff --git a/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2-r1 b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2-r1
new file mode 100644
index 000000000000..de4826610abb
--- /dev/null
+++ b/games-rpg/eternal-lands/files/digest-eternal-lands-1.3.2-r1
@@ -0,0 +1,6 @@
+MD5 39f027d682186b11382c8b6e5acfd2a0 elc_132.tar.bz2 837127
+RMD160 07ddc2c87054ec80139b76b16502b8308b286c4b elc_132.tar.bz2 837127
+SHA256 10f65992de9fe938ef93e2056dfd8dea9d351b48410fdda1f2bf2913af829982 elc_132.tar.bz2 837127
+MD5 059df8128b11b19a76b54e9907072f00 eternal-lands.png 9955
+RMD160 2f9c8acd96214577cf8b8027f0d20fb1fe7574ff eternal-lands.png 9955
+SHA256 dd7d45cd9948fe7875ebd0bfcd1925d9b34e7606a223faf61d37a6dd2cd433fb eternal-lands.png 9955