summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-06 03:22:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-06 03:22:43 +0000
commitdd5ab71a4d28eb4d500a7b81e7d5087612eb05b4 (patch)
treee55705e5e384ab6a914bae3124827ee5c1c2a7f0 /games-rpg
parentbackporting IBM JDK fix to _pre7 (diff)
downloadgentoo-2-dd5ab71a4d28eb4d500a7b81e7d5087612eb05b4.tar.gz
gentoo-2-dd5ab71a4d28eb4d500a7b81e7d5087612eb05b4.tar.bz2
gentoo-2-dd5ab71a4d28eb4d500a7b81e7d5087612eb05b4.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/tmw/ChangeLog7
-rw-r--r--games-rpg/tmw/Manifest6
-rw-r--r--games-rpg/tmw/files/digest-tmw-0.0.141
-rw-r--r--games-rpg/tmw/tmw-0.0.14.ebuild46
4 files changed, 57 insertions, 3 deletions
diff --git a/games-rpg/tmw/ChangeLog b/games-rpg/tmw/ChangeLog
index d6cfc0dd0618..4951ce631014 100644
--- a/games-rpg/tmw/ChangeLog
+++ b/games-rpg/tmw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/tmw
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.4 2005/06/15 19:08:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/ChangeLog,v 1.5 2005/07/06 03:22:43 mr_bones_ Exp $
+
+*tmw-0.0.14 (06 Jul 2005)
+
+ 06 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org> +tmw-0.0.14.ebuild:
+ version bump
15 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> tmw-0.0.12.ebuild,
tmw-0.0.13.ebuild:
diff --git a/games-rpg/tmw/Manifest b/games-rpg/tmw/Manifest
index 80d5dbb32f3f..292afdc88446 100644
--- a/games-rpg/tmw/Manifest
+++ b/games-rpg/tmw/Manifest
@@ -1,7 +1,9 @@
-MD5 126ec7779fedf8891b7cf24079acd5c6 ChangeLog 721
+MD5 5133625a96ca4cbb0c9f7cf2f384e081 tmw-0.0.14.ebuild 1126
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 9cf213728df3e972581610a45a78ea07 tmw-0.0.12.ebuild 1014
MD5 3c4882835798dc845a1c834b413c10ed tmw-0.0.13.ebuild 1127
+MD5 126ec7779fedf8891b7cf24079acd5c6 ChangeLog 721
+MD5 3413e54c956f8f6737a2e0752054959d files/digest-tmw-0.0.13 63
MD5 28ec001a7bdc25f73730cb5e99d2298f files/digest-tmw-0.0.12 63
MD5 6e873b44081c25fa618a3bd28d74f86c files/tmw-0.0.12-desktop.patch 757
-MD5 3413e54c956f8f6737a2e0752054959d files/digest-tmw-0.0.13 63
+MD5 77c301fb13e72c51fafa865b4dd853c2 files/digest-tmw-0.0.14 63
diff --git a/games-rpg/tmw/files/digest-tmw-0.0.14 b/games-rpg/tmw/files/digest-tmw-0.0.14
new file mode 100644
index 000000000000..7aad2fe458ec
--- /dev/null
+++ b/games-rpg/tmw/files/digest-tmw-0.0.14
@@ -0,0 +1 @@
+MD5 21cb60f61ef55b261ea75eaea7317026 tmw-0.0.14.tar.gz 1439918
diff --git a/games-rpg/tmw/tmw-0.0.14.ebuild b/games-rpg/tmw/tmw-0.0.14.ebuild
new file mode 100644
index 000000000000..82931959728a
--- /dev/null
+++ b/games-rpg/tmw/tmw-0.0.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/tmw/tmw-0.0.14.ebuild,v 1.1 2005/07/06 03:22:43 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A fully free and open source MMORPG game with the looks of \"old-fashioned\" 2D RPG"
+HOMEPAGE="http://themanaworld.org"
+SRC_URI="mirror://sourceforge/themanaworld/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl"
+
+DEPEND=">=dev-games/physfs-1.0.0
+ opengl? ( virtual/opengl )
+ dev-libs/libxml2
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ >=dev-games/guichan-0.4.0"
+
+pkg_setup() {
+ if ! built_with_use dev-games/guichan sdl ; then
+ eerror "dev-games/guichan needs to be built with USE=sdl"
+ die "please re-emerge guichan with USE=sdl"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.0.12-desktop.patch
+}
+
+src_compile() {
+ egamesconf $(use_with opengl) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}