summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-11-02 14:15:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-11-02 14:15:08 +0000
commit0e75e646d43c69ae27d422111696302c4b2e39a0 (patch)
treea48d6cb0f9f65e507b80fd6babf84a4c0ff7d9e3 /games-server/cyphesis
parentversion bump (diff)
downloadgentoo-2-0e75e646d43c69ae27d422111696302c4b2e39a0.tar.gz
gentoo-2-0e75e646d43c69ae27d422111696302c4b2e39a0.tar.bz2
gentoo-2-0e75e646d43c69ae27d422111696302c4b2e39a0.zip
Version bump to 0.6.2
(Portage version: 2.2.7/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-server/cyphesis')
-rw-r--r--games-server/cyphesis/ChangeLog8
-rw-r--r--games-server/cyphesis/cyphesis-0.6.2.ebuild60
-rw-r--r--games-server/cyphesis/files/cyphesis-0.6.2-gentoo.patch32
-rw-r--r--games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch11
4 files changed, 110 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 1f02aae8bfb2..1a957f126c98 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.33 2013/10/02 07:56:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.34 2013/11/02 14:15:07 tupone Exp $
+
+*cyphesis-0.6.2 (02 Nov 2013)
+
+ 02 Nov 2013; Tupone Alfredo <tupone@gentoo.org> +cyphesis-0.6.2.ebuild,
+ +files/cyphesis-0.6.2-gentoo.patch, +files/cyphesis-0.6.2-makefile.patch:
+ Version bump to 0.6.2
*cyphesis-0.6.1 (02 Oct 2013)
diff --git a/games-server/cyphesis/cyphesis-0.6.2.ebuild b/games-server/cyphesis/cyphesis-0.6.2.ebuild
new file mode 100644
index 000000000000..5cfcb9e44482
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.6.2.ebuild,v 1.1 2013/11/02 14:15:08 tupone Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit toolchain-funcs autotools python-single-r1 eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=media-libs/skstream-0.3.9
+ >=dev-games/wfmath-1.0.1
+ >=dev-games/mercator-0.3.3
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ >=media-libs/atlas-c++-0.6.3
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.6.2-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.6.2-gentoo.patch
new file mode 100644
index 000000000000..69aac409ba8d
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.6.2-gentoo.patch
@@ -0,0 +1,32 @@
+diff -ru cyphesis-0.6.0.orig/Makefile.am cyphesis-0.6.0/Makefile.am
+--- cyphesis-0.6.0.orig/Makefile.am 2012-10-02 06:23:10.000000000 -0400
++++ cyphesis-0.6.0/Makefile.am 2012-11-12 16:54:19.306892135 -0500
+@@ -3,7 +3,6 @@
+ tools tests man dox
+
+ docdir = $(datadir)/doc/cyphesis-$(VERSION)
+-dist_doc_DATA = README COPYING AUTHORS THANKS NEWS FIXME
+
+ rulesetdir = $(datadir)/cyphesis/rulesets
+
+diff -ru cyphesis-0.6.0.orig/configure.ac cyphesis-0.6.0/configure.ac
+--- cyphesis-0.6.0.orig/configure.ac 2012-11-09 16:39:13.000000000 -0500
++++ cyphesis-0.6.0/configure.ac 2012-11-12 16:53:51.622839335 -0500
+@@ -381,17 +381,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
diff --git a/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch b/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
new file mode 100644
index 000000000000..99ca3872c040
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.6.2-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.am.old 2013-09-25 14:26:30.518751250 +0200
++++ Makefile.am 2013-09-25 14:27:21.846257911 +0200
+@@ -13,8 +13,6 @@
+
+ # FIXME Remove the mkdir hack if it gets fixed in a future automake
+ install-data-hook:
+- mkdir -p $(DESTDIR)$(socketdir)
+- chmod 1777 $(DESTDIR)$(socketdir)
+ @echo
+ @echo "Cyphesis is not yet ready to run."
+ @echo "Unless you have configured the server to run without a database, Cyphesis"