summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-31 06:45:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-31 06:45:38 +0000
commitbf57cdd0400feafe4b31c790f4c1022717c15cca (patch)
tree3709bed1cffb71fbb4f8ee8b68e106f5c2706089 /games-server/cyphesis
parentadded missing dmenu dependency. pass VERSION to emake if <9999. (diff)
downloadgentoo-2-bf57cdd0400feafe4b31c790f4c1022717c15cca.tar.gz
gentoo-2-bf57cdd0400feafe4b31c790f4c1022717c15cca.tar.bz2
gentoo-2-bf57cdd0400feafe4b31c790f4c1022717c15cca.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-server/cyphesis')
-rw-r--r--games-server/cyphesis/ChangeLog16
-rw-r--r--games-server/cyphesis/cyphesis-0.5.24.ebuild54
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch10
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.24-gentoo.patch41
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.24-python27.patch22
5 files changed, 142 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 8fe032f2071f..529136736186 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.12 2010/06/17 18:33:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.13 2010/08/31 06:45:38 mr_bones_ Exp $
+
+ 31 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +cyphesis-0.5.24.ebuild, +files/cyphesis-0.5.24-gcc45.patch,
+ +files/cyphesis-0.5.24-gentoo.patch,
+ +files/cyphesis-0.5.24-python27.patch:
+ version bump
+
+*cyphesis-0.5.24 (31 Aug 2010)
+
+ 31 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +cyphesis-0.5.24.ebuild, +files/cyphesis-0.5.24-gcc45.patch,
+ +files/cyphesis-0.5.24-gentoo.patch,
+ +files/cyphesis-0.5.24-python27.patch:
+ version bump
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> cyphesis-0.5.22.ebuild:
Migrating away from deprecated postgres virtuals
diff --git a/games-server/cyphesis/cyphesis-0.5.24.ebuild b/games-server/cyphesis/cyphesis-0.5.24.ebuild
new file mode 100644
index 000000000000..ceb83a0cd411
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.5.24.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.24.ebuild,v 1.1 2010/08/31 06:45:38 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+inherit autotools python eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/skstream-0.3.6
+ >=dev-games/wfmath-0.3.9
+ =dev-games/mercator-0.2*
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-python27.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch b/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch
new file mode 100644
index 000000000000..7e5c33da049c
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.24-gcc45.patch
@@ -0,0 +1,10 @@
+--- physics/Collision.h.old 2010-05-19 14:31:30.000000000 +0200
++++ physics/Collision.h 2010-05-19 14:31:44.000000000 +0200
+@@ -22,6 +22,7 @@
+
+ #include "physics/Vector3D.h"
+
++#include <wfmath/point.h>
+ #include <wfmath/axisbox.h>
+
+ #include <map>
diff --git a/games-server/cyphesis/files/cyphesis-0.5.24-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.24-gentoo.patch
new file mode 100644
index 000000000000..73e65966fe94
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.24-gentoo.patch
@@ -0,0 +1,41 @@
+diff -ur cyphesis-0.5.20.orig/configure.ac cyphesis-0.5.20/configure.ac
+--- cyphesis-0.5.20.orig/configure.ac 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/configure.ac 2009-08-15 12:33:01.000000000 +0300
+@@ -342,26 +342,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
+diff -ur cyphesis-0.5.20.orig/Makefile.am cyphesis-0.5.20/Makefile.am
+--- cyphesis-0.5.20.orig/Makefile.am 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/Makefile.am 2009-08-15 12:33:45.000000000 +0300
+@@ -3,7 +3,6 @@
+ tools tests man dox
+
+ docdir = $(datadir)/doc/cyphesis-$(VERSION)
+-dist_doc_DATA = README COPYING AUTHORS THANKS NEWS FIXME
+
+ rulesetdir = $(datadir)/cyphesis/rulesets
+
diff --git a/games-server/cyphesis/files/cyphesis-0.5.24-python27.patch b/games-server/cyphesis/files/cyphesis-0.5.24-python27.patch
new file mode 100644
index 000000000000..85ef14f9dda0
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.24-python27.patch
@@ -0,0 +1,22 @@
+--- configure.ac.orig 2010-08-31 00:02:13.261828627 -0400
++++ configure.ac 2010-08-31 00:03:30.094023860 -0400
+@@ -162,6 +162,11 @@
+ dnl if found define HAVE_PYTHON_H
+ dnl
+
++AC_CHECK_HEADER(python2.7/Python.h,
++[
++ python_include_path=-I${python_prefix}/include/python2.7
++ python_version=2.7
++],[
+ AC_CHECK_HEADER(python2.6/Python.h,
+ [
+ python_include_path=-I${python_prefix}/include/python2.6
+@@ -197,6 +202,7 @@
+ ])
+ ])
+ ])
++])
+
+ PYTHON_VERSION=${python_version}
+ PYTHON_INCLUDES=${python_include_path}