summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 17:24:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 17:24:08 +0000
commit47a0fa93e4f6ff8d407e63cbd91355ddfa340a46 (patch)
treef3ee3fd34368cb38fee820ee481ddf1e456a8a0f /games-server
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-47a0fa93e4f6ff8d407e63cbd91355ddfa340a46.tar.gz
gentoo-2-47a0fa93e4f6ff8d407e63cbd91355ddfa340a46.tar.bz2
gentoo-2-47a0fa93e4f6ff8d407e63cbd91355ddfa340a46.zip
Version bump wrt #273547, thanks to Pacho Ramos for reporting.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/cyphesis/ChangeLog10
-rw-r--r--games-server/cyphesis/cyphesis-0.5.20.ebuild46
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.20-gcc44.patch13
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.20-gentoo.patch41
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.20-python26.patch45
5 files changed, 154 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 44624a590a92..11f3b9cac904 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.8 2009/01/02 03:59:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.9 2009/08/15 17:24:08 ssuominen Exp $
+
+*cyphesis-0.5.20 (15 Aug 2009)
+
+ 15 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +cyphesis-0.5.20.ebuild, +files/cyphesis-0.5.20-gcc44.patch,
+ +files/cyphesis-0.5.20-gentoo.patch,
+ +files/cyphesis-0.5.20-python26.patch:
+ Version bump wrt #273547, thanks to Pacho Ramos for reporting.
02 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
-files/cyphesis-0.5.15-gentoo.patch, -cyphesis-0.5.15.ebuild,
diff --git a/games-server/cyphesis/cyphesis-0.5.20.ebuild b/games-server/cyphesis/cyphesis-0.5.20.ebuild
new file mode 100644
index 000000000000..b15e8f6d89ce
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.5.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.20.ebuild,v 1.1 2009/08/15 17:24:08 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/skstream-0.3.6
+ >=dev-games/wfmath-0.3.9
+ =dev-games/mercator-0.2*
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ virtual/postgresql-base"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-python26.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.20-gcc44.patch b/games-server/cyphesis/files/cyphesis-0.5.20-gcc44.patch
new file mode 100644
index 000000000000..05925d1d8401
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.20-gcc44.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/DateTimetest.cpp b/tests/DateTimetest.cpp
+index 0417349..2691c65 100644
+--- a/tests/DateTimetest.cpp
++++ b/tests/DateTimetest.cpp
+@@ -23,6 +23,8 @@
+
+ #include <cassert>
+
++#include <cstdio>
++
+ int main()
+ {
+ DateTime datum(0);
diff --git a/games-server/cyphesis/files/cyphesis-0.5.20-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.20-gentoo.patch
new file mode 100644
index 000000000000..73e65966fe94
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.20-gentoo.patch
@@ -0,0 +1,41 @@
+diff -ur cyphesis-0.5.20.orig/configure.ac cyphesis-0.5.20/configure.ac
+--- cyphesis-0.5.20.orig/configure.ac 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/configure.ac 2009-08-15 12:33:01.000000000 +0300
+@@ -342,26 +342,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
+diff -ur cyphesis-0.5.20.orig/Makefile.am cyphesis-0.5.20/Makefile.am
+--- cyphesis-0.5.20.orig/Makefile.am 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/Makefile.am 2009-08-15 12:33:45.000000000 +0300
+@@ -3,7 +3,6 @@
+ tools tests man dox
+
+ docdir = $(datadir)/doc/cyphesis-$(VERSION)
+-dist_doc_DATA = README COPYING AUTHORS THANKS NEWS FIXME
+
+ rulesetdir = $(datadir)/cyphesis/rulesets
+
diff --git a/games-server/cyphesis/files/cyphesis-0.5.20-python26.patch b/games-server/cyphesis/files/cyphesis-0.5.20-python26.patch
new file mode 100644
index 000000000000..373bbfe8c700
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.20-python26.patch
@@ -0,0 +1,45 @@
+diff -ur cyphesis-0.5.20.orig/configure.ac cyphesis-0.5.20/configure.ac
+--- cyphesis-0.5.20.orig/configure.ac 2009-05-11 15:23:20.000000000 +0300
++++ cyphesis-0.5.20/configure.ac 2009-08-15 12:28:19.000000000 +0300
+@@ -161,28 +161,28 @@
+ dnl if found define HAVE_PYTHON_H
+ dnl
+
+-AC_CHECK_HEADER(python2.5/Python.h,
++AC_CHECK_HEADER(python2.6/Python.h,
+ [
+- python_include_path=-I${python_prefix}/include/python2.5
+- python_version=2.5
++ python_include_path=-I${python_prefix}/include/python2.6
++ python_version=2.6
+ ],[
+- AC_CHECK_HEADER(python2.4/Python.h,
++ AC_CHECK_HEADER(python2.5/Python.h,
+ [
+- python_include_path=-I${python_prefix}/include/python2.4
+- python_version=2.4
++ python_include_path=-I${python_prefix}/include/python2.5
++ python_version=2.5
+ ],[
+- AC_CHECK_HEADER(python2.3/Python.h,
++ AC_CHECK_HEADER(python2.4/Python.h,
+ [
+- python_include_path=-I${python_prefix}/include/python2.3
+- python_version=2.3
++ python_include_path=-I${python_prefix}/include/python2.4
++ python_version=2.4
+ ],[
+- AC_CHECK_HEADER(python2.2/Python.h,
++ AC_CHECK_HEADER(python2.3/Python.h,
+ [
+- python_include_path=-I${python_prefix}/include/python2.2
+- python_version=2.2
++ python_include_path=-I${python_prefix}/include/python2.3
++ python_version=2.3
+ ],[
+ AC_MSG_ERROR([
+-Cannot find python headers for Python 2.2 or later.
++Cannot find python headers for Python 2.3 or later.
+ Please see http://www.python.org/ for details of how to download and install
+ Python. If Python is installed somewhere other than in /usr the please use the
+ --with-python=DIR option to point to the prefix where Python is installed.])