summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-12 23:40:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-12 23:40:13 +0000
commit82206be7f271aecc04a01653fca0c5cdf55b8bc6 (patch)
tree77fafef81ef938165f3fba2a9d4cb3a66eff1d73 /games-simulation/lincity
parentarm stable, bug #300483 (diff)
downloadgentoo-2-82206be7f271aecc04a01653fca0c5cdf55b8bc6.tar.gz
gentoo-2-82206be7f271aecc04a01653fca0c5cdf55b8bc6.tar.bz2
gentoo-2-82206be7f271aecc04a01653fca0c5cdf55b8bc6.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation/lincity')
-rw-r--r--games-simulation/lincity/ChangeLog8
-rw-r--r--games-simulation/lincity/lincity-1.12.1.ebuild32
2 files changed, 25 insertions, 15 deletions
diff --git a/games-simulation/lincity/ChangeLog b/games-simulation/lincity/ChangeLog
index e31d7b232b72..cc62d8cc6de8 100644
--- a/games-simulation/lincity/ChangeLog
+++ b/games-simulation/lincity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/lincity
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/ChangeLog,v 1.17 2008/02/05 21:16:49 grobian Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/ChangeLog,v 1.18 2010/01/12 23:40:13 mr_bones_ Exp $
+
+ 12 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ lincity-1.12.1.ebuild:
+ EAPI=2
05 Feb 2008; Fabian Groffen <grobian@gentoo.org> lincity-1.12.1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/games-simulation/lincity/lincity-1.12.1.ebuild b/games-simulation/lincity/lincity-1.12.1.ebuild
index d8a7149d0e40..0f1312e95595 100644
--- a/games-simulation/lincity/lincity-1.12.1.ebuild
+++ b/games-simulation/lincity/lincity-1.12.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/lincity-1.12.1.ebuild,v 1.8 2008/02/05 21:16:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/lincity/lincity-1.12.1.ebuild,v 1.9 2010/01/12 23:40:13 mr_bones_ Exp $
-inherit games
+EAPI=2
+inherit eutils games
DESCRIPTION="city/country simulation game for X and Linux SVGALib"
HOMEPAGE="http://lincity.sourceforge.net/"
@@ -25,8 +26,16 @@ RDEPEND="nls? ( virtual/libintl )
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_compile() {
- local myconf=
+src_prepare() {
+ sed -i \
+ -e '/^localedir/s:$(datadir):/usr/share:' \
+ po/Makefile.in.in \
+ intl/Makefile.in \
+ || die 'sed failed'
+}
+
+src_configure() {
+ local myconf
if ! use X && ! use svga ; then
myconf="--with-x"
@@ -37,17 +46,14 @@ src_compile() {
$(use_enable nls) \
$(use_with svga) \
$(use_with X x) \
- ${myconf} \
- || die
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc Acknowledgements CHANGES README* TODO || die "dodoc failed"
- if use nls ; then
- cd "${D}/${GAMES_DATADIR}"
- mv locale "${D}/usr/share/"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Acknowledgements CHANGES README* TODO
+ if use X || ! use svga ; then
+ make_desktop_entry xlincity Lincity
fi
prepgamesdirs
}