summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-26 22:25:55 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-26 22:25:55 +0000
commit14699c3001ace11e7ebac341ef4873265acd9267 (patch)
tree3fb470663699e29d0b642bef3bd6412ee13317d4 /games-simulation/openttd
parentRemoved USE= typo to close bug #55251. 1.7 is stable amd64. (Manifest recommit) (diff)
downloadgentoo-2-14699c3001ace11e7ebac341ef4873265acd9267.tar.gz
gentoo-2-14699c3001ace11e7ebac341ef4873265acd9267.tar.bz2
gentoo-2-14699c3001ace11e7ebac341ef4873265acd9267.zip
Initial import, ebuild by Hinrik rn Sigur
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog10
-rw-r--r--games-simulation/openttd/Manifest4
-rw-r--r--games-simulation/openttd/files/digest-openttd-200406262
-rw-r--r--games-simulation/openttd/metadata.xml9
-rw-r--r--games-simulation/openttd/openttd-20040626.ebuild83
5 files changed, 108 insertions, 0 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
new file mode 100644
index 000000000000..6f6dce9df198
--- /dev/null
+++ b/games-simulation/openttd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-simulation/openttd
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.1 2004/06/26 22:25:55 dholm Exp $
+
+*openttd-20040626 (27 Jun 2004)
+
+ 27 Jun 2004; David Holm <dholm@gentoo.org> +openttd-20040626.ebuild:
+ Initial import, ebuild by Hinrik Örn Sigurðsson <flanders at simnet dot is>
+ (bug #49113).
+
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
new file mode 100644
index 000000000000..7856c19edeb8
--- /dev/null
+++ b/games-simulation/openttd/Manifest
@@ -0,0 +1,4 @@
+MD5 301f803c8debe5bc04fbf34d53b97da0 ChangeLog 324
+MD5 2a1397213b32971994e799bc06c50c14 openttd-20040626.ebuild 2121
+MD5 7efefbbe81a05cbc5d4e96203f047fda metadata.xml 245
+MD5 d843b4d40c78f879ad70c5cc231bd815 files/digest-openttd-20040626 133
diff --git a/games-simulation/openttd/files/digest-openttd-20040626 b/games-simulation/openttd/files/digest-openttd-20040626
new file mode 100644
index 000000000000..0df5de544b23
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-20040626
@@ -0,0 +1,2 @@
+MD5 7cbdb28a65b6360f9d6c5cf8ec51d2d8 openttd-20040626.tar.bz2 1654861
+MD5 070d66ed5086515a45f0a40a25c28771 openttd-useful.zip 366311
diff --git a/games-simulation/openttd/metadata.xml b/games-simulation/openttd/metadata.xml
new file mode 100644
index 000000000000..dcdc50e5418e
--- /dev/null
+++ b/games-simulation/openttd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>dholm@gentoo.org</email>
+ <name>David Holm</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-simulation/openttd/openttd-20040626.ebuild b/games-simulation/openttd/openttd-20040626.ebuild
new file mode 100644
index 000000000000..5cc15106a24f
--- /dev/null
+++ b/games-simulation/openttd/openttd-20040626.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-20040626.ebuild,v 1.1 2004/06/26 22:25:55 dholm Exp $
+
+inherit games
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://sourceforge/openttd/openttd-useful.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug png zlib"
+DEPEND="virtual/libc
+ media-libs/libsdl
+ media-sound/timidity++
+ media-sound/timidity-eawpatches
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+
+ # unpack the title screen
+ mkdir ${WORKDIR}/useful
+ cd ${WORKDIR}/useful
+ unpack openttd-useful.zip
+}
+
+src_compile() {
+ # parallel make causes problems
+ MAKEOPTS="${MAKEOPTS} -j1"
+
+ local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_SDL=1 WITH_NETWORK=1 USE_HOMEDIR=1 PERSONAL_DIR=.openttd GAME_DATA_DIR=${GAMES_DATADIR}/${PN}/"
+ use debug && myopts="${myopts} DEBUG=1"
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+
+ emake ${myopts} || die "emake failed"
+}
+
+src_install() {
+ exeinto ${GAMES_BINDIR}
+ doexe ttd
+
+ # openttd doesn't create ~/.openttd/ so we must do that inside the wrapper
+ #games_make_wrapper openttd "./ttd -m extmidi" ${GAMES_BINDIR}
+
+ cat << EOF > ${D}/${GAMES_BINDIR}/openttd
+#!/bin/sh
+test -d ~/.openttd/ || mkdir -p ~/.openttd
+cd ${GAMES_BINDIR}
+exec ./ttd -m extmidi "\$@"
+EOF
+
+ insinto ${GAMES_DATADIR}/${PN}/data
+ doins data/*
+ doins ${WORKDIR}/useful/opntitle.dat
+
+ insinto ${GAMES_DATADIR}/${PN}/lang
+ doins lang/*.lng
+
+ insinto /usr/share/pixmaps
+ newins media/icon128.png openttd.png
+
+ make_desktop_entry openttd "OpenTTD" openttd.png
+ dodoc readme.txt changelog.txt docs/Manual.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "the *WINDOWS* version of TTD to ${GAMES_DATADIR}/${PN}/data/"
+ einfo ""
+ einfo "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo ""
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ einfo ""
+}