summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-04 06:58:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-04 06:58:18 +0000
commit82031c335889a48b4b0de4d0d4a5d512e39bfcbc (patch)
tree1acfd9006c143ada250063c6fa15b437d24f03ba /games-simulation/simutrans
parentadd zip rdep (bug #437126) (diff)
downloadgentoo-2-82031c335889a48b4b0de4d0d4a5d512e39bfcbc.tar.gz
gentoo-2-82031c335889a48b4b0de4d0d4a5d512e39bfcbc.tar.bz2
gentoo-2-82031c335889a48b4b0de4d0d4a5d512e39bfcbc.zip
Build with gcc-4.7 Bug #423653
(Portage version: 2.1.11.23/cvs/Linux i686)
Diffstat (limited to 'games-simulation/simutrans')
-rw-r--r--games-simulation/simutrans/ChangeLog6
-rw-r--r--games-simulation/simutrans/files/simutrans-0.102.2.2-gcc47.patch59
-rw-r--r--games-simulation/simutrans/simutrans-0.102.2.2.ebuild3
3 files changed, 66 insertions, 2 deletions
diff --git a/games-simulation/simutrans/ChangeLog b/games-simulation/simutrans/ChangeLog
index 6d6a7f918e37..182d9e128b0c 100644
--- a/games-simulation/simutrans/ChangeLog
+++ b/games-simulation/simutrans/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/simutrans
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.28 2012/03/23 20:14:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/ChangeLog,v 1.29 2012/10/04 06:58:18 tupone Exp $
+
+ 04 Oct 2012; Tupone Alfredo <tupone@gentoo.org> simutrans-0.102.2.2.ebuild,
+ +files/simutrans-0.102.2.2-gcc47.patch:
+ Build with gcc-4.7 Bug #423653 by Diego
23 Mar 2012; Tupone Alfredo <tupone@gentoo.org> simutrans-0.102.2.2.ebuild,
+files/simutrans-0.102.2.2-zlib.patch:
diff --git a/games-simulation/simutrans/files/simutrans-0.102.2.2-gcc47.patch b/games-simulation/simutrans/files/simutrans-0.102.2.2-gcc47.patch
new file mode 100644
index 000000000000..31c8fff31014
--- /dev/null
+++ b/games-simulation/simutrans/files/simutrans-0.102.2.2-gcc47.patch
@@ -0,0 +1,59 @@
+--- gui/curiositylist_stats_t.cc.old 2012-10-04 08:46:47.623621825 +0200
++++ gui/curiositylist_stats_t.cc 2012-10-04 08:47:12.429854860 +0200
+@@ -151,7 +151,8 @@
+ get_unique_attractions( sortby, sortreverse );
+ }
+
+- for (uint32 i=0; i<attractions.get_count() && yoff<end; i++) {
++ uint32 i;
++ for (i=0; i<attractions.get_count() && yoff<end; i++) {
+ const gebaeude_t* geb = attractions[i];
+
+ int xoff = offset.x+10;
+--- tpl/hashtable_tpl.h.old 2012-10-03 13:51:30.558014602 +0200
++++ tpl/hashtable_tpl.h 2012-10-03 17:18:43.988237496 +0200
+@@ -48,7 +48,7 @@
+ while(iter.next()) {
+ node_t node = iter.get_current();
+
+- if(comp(node.key, key) == 0) {
++ if(this->comp(node.key, key) == 0) {
+ return node.object;
+ }
+ }
+@@ -61,7 +61,7 @@
+ while(iter.next()) {
+ node_t &node = iter.access_current();
+
+- if(comp(node.key, key) == 0) {
++ if(this->comp(node.key, key) == 0) {
+ return &node.object;
+ }
+ }
+@@ -84,7 +84,7 @@
+ while(iter.next()) {
+ node_t &node = iter.access_current();
+
+- if(comp(node.key, key) == 0) {
++ if(this->comp(node.key, key) == 0) {
+ // duplicate
+ return false;
+ }
+@@ -111,7 +111,7 @@
+
+ while(iter.next()) {
+ node_t &node = iter.access_current();
+- if(comp(node.key, key) == 0) {
++ if(this->comp(node.key, key) == 0) {
+ value_t value = node.object;
+ node.object = object;
+ return value;
+@@ -138,7 +138,7 @@
+
+ while(iter.next()) {
+ node_t node = iter.get_current();
+- if(comp(node.key, key) == 0) {
++ if(this->comp(node.key, key) == 0) {
+ bags[code].remove( node );
+
+ return node.object;
diff --git a/games-simulation/simutrans/simutrans-0.102.2.2.ebuild b/games-simulation/simutrans/simutrans-0.102.2.2.ebuild
index 26458a2286a5..f5555c2abfdc 100644
--- a/games-simulation/simutrans/simutrans-0.102.2.2.ebuild
+++ b/games-simulation/simutrans/simutrans-0.102.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.102.2.2.ebuild,v 1.5 2012/03/23 20:14:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/simutrans/simutrans-0.102.2.2.ebuild,v 1.6 2012/10/04 06:58:18 tupone Exp $
EAPI=2
inherit flag-o-matic eutils games
@@ -53,6 +53,7 @@ FLAGS=-DSTEPS16" > config.default \
rm -f simutrans/simutrans
epatch "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-zlib.patch
}