summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-12 13:35:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-12 13:35:58 +0000
commit38232db1dcd097026e57d470c04cfa801ec9e174 (patch)
tree2ccb22989aa270d52123d53c401e6acb56cfb856 /games-simulation
parentnew gnat.eclass - libs are making use of split gnat-xxx compilers now (diff)
downloadgentoo-2-38232db1dcd097026e57d470c04cfa801ec9e174.tar.gz
gentoo-2-38232db1dcd097026e57d470c04cfa801ec9e174.tar.bz2
gentoo-2-38232db1dcd097026e57d470c04cfa801ec9e174.zip
Fixed dependencies for modular X and changed to use binary libopenal.so.0 instead of the system one, for compatibility with the new split openal/freealut.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/bcs-demo/ChangeLog7
-rw-r--r--games-simulation/bcs-demo/bcs-demo-1.3.ebuild34
-rw-r--r--games-simulation/bcs-demo/files/digest-bcs-demo-1.33
3 files changed, 37 insertions, 7 deletions
diff --git a/games-simulation/bcs-demo/ChangeLog b/games-simulation/bcs-demo/ChangeLog
index 6865401ce8ee..032807a4d366 100644
--- a/games-simulation/bcs-demo/ChangeLog
+++ b/games-simulation/bcs-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/bcsdemo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/ChangeLog,v 1.2 2006/04/18 13:18:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/ChangeLog,v 1.3 2006/05/12 13:35:58 wolf31o2 Exp $
+
+ 12 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> bcs-demo-1.3.ebuild:
+ Fixed dependencies for modular X and changed to use binary libopenal.so.0
+ instead of the system one, for compatibility with the new split
+ openal/freealut.
18 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org> bcs-demo-1.3.ebuild:
Changed to use GAMES_CHECK_LICENSE and some general cleanup.
diff --git a/games-simulation/bcs-demo/bcs-demo-1.3.ebuild b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
index ac04f71028f5..28a4013b0112 100644
--- a/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
+++ b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
@@ -1,19 +1,33 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/bcs-demo-1.3.ebuild,v 1.2 2006/04/18 13:18:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/bcs-demo/bcs-demo-1.3.ebuild,v 1.3 2006/05/12 13:35:58 wolf31o2 Exp $
inherit eutils games
DESCRIPTION="design and build bridges and then stress test them with trains"
HOMEPAGE="http://garagegames.com/pg/product/view.php?id=17"
-SRC_URI="ftp://ggdev-1.homelan.com/bcs/bcsdemo_v${PV/./_}.sh.bin"
+SRC_URI="ftp://ggdev-1.homelan.com/bcs/bcsdemo_v${PV/./_}.sh.bin
+ http://www.highprogrammer.com/alan/pfx2/openal-alan-hack-0.0.1.tar.gz"
LICENSE="BCS"
SLOT="0"
KEYWORDS="-* x86"
IUSE=""
-RDEPEND="media-libs/openal"
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ x86? (
+ media-libs/libsdl
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 ) )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-sdl )"
S=${WORKDIR}
@@ -22,17 +36,25 @@ dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
src_unpack() {
- unpack_makeself
+ unpack_makeself bcsdemo_v${PV/./_}.sh.bin
+ unpack openal-alan-hack-0.0.1.tar.gz
}
src_install() {
dodir ${dir} ${GAMES_BINDIR}
tar -zxf bcsdemo.tar.gz -C ${Ddir} || die "extracting bcsdemo.tar.gz"
+ rm -f ${Ddir}/bcs-linux-openal-fixer.sh
exeinto ${dir}
- doexe bin/Linux/x86/rungame.sh || die
- dosym ${dir}/rungame.sh ${GAMES_BINDIR}/bcs-demo
+# doexe bin/Linux/x86/rungame.sh || die
+# exeinto ${dir}/lib
+ mv ${Ddir}/bcs ${Ddir}/bcs-bin
+ newexe libopenal.so.0.0.6 libopenal.so.0 || die
+ echo '#!/bin/bash' >> ${Ddir}/bcs
+ echo 'LD_PRELOAD="./libopenal.so.0" ./bcs-bin' >> ${Ddir}/bcs
+ fperms 750 ${dir}/bcs
+ games_make_wrapper bcs-demo ./bcs "${dir}" "${dir}"
insinto ${dir}
doins *.cfg || die
diff --git a/games-simulation/bcs-demo/files/digest-bcs-demo-1.3 b/games-simulation/bcs-demo/files/digest-bcs-demo-1.3
index 04b96f1ac1ef..3a2f6baa88d7 100644
--- a/games-simulation/bcs-demo/files/digest-bcs-demo-1.3
+++ b/games-simulation/bcs-demo/files/digest-bcs-demo-1.3
@@ -1,3 +1,6 @@
MD5 ed370f8925f573429ffd810703149ca8 bcsdemo_v1_3.sh.bin 5965217
RMD160 ee9af7683c389b2ed211a9c7db8fd7a94c135480 bcsdemo_v1_3.sh.bin 5965217
SHA256 1e23f1fd2ec95e27c56037761c25e3af1ef1f23365540434b12e8b31527dbad7 bcsdemo_v1_3.sh.bin 5965217
+MD5 5c61c76b265fbd6e5f5c133a60348b01 openal-alan-hack-0.0.1.tar.gz 86168
+RMD160 edaa7fe9715837a340c7cb96585707557481c8a3 openal-alan-hack-0.0.1.tar.gz 86168
+SHA256 86e09a5d43461031094c1a09382b369c6f8e231e644dde9d98b7b35fb2e0767a openal-alan-hack-0.0.1.tar.gz 86168