summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-30 11:35:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-30 11:35:24 +0000
commit6b7dfef5fbc8a291e62e8bfef6804a27419ac21d (patch)
tree2f6dc46be40c937cdcee9f967ceb1cb7c71f32a7 /games-simulation
parentClosing #45280. (Manifest recommit) (diff)
downloadgentoo-2-6b7dfef5fbc8a291e62e8bfef6804a27419ac21d.tar.gz
gentoo-2-6b7dfef5fbc8a291e62e8bfef6804a27419ac21d.tar.bz2
gentoo-2-6b7dfef5fbc8a291e62e8bfef6804a27419ac21d.zip
initial commit; ebuild based on the one submitted by Andreas Scholta via bug #40738
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/pmars-sdl/ChangeLog11
-rw-r--r--games-simulation/pmars-sdl/Manifest2
-rw-r--r--games-simulation/pmars-sdl/files/digest-pmars-sdl-0.9.2e1
-rw-r--r--games-simulation/pmars-sdl/metadata.xml5
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild92
5 files changed, 111 insertions, 0 deletions
diff --git a/games-simulation/pmars-sdl/ChangeLog b/games-simulation/pmars-sdl/ChangeLog
new file mode 100644
index 000000000000..011ce1bdd773
--- /dev/null
+++ b/games-simulation/pmars-sdl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-simulation/pmars-sdl
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/ChangeLog,v 1.1 2004/03/30 11:35:24 mr_bones_ Exp $
+
+*pmars-sdl-0.9.2e (30 Mar 2004)
+
+ 30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ pmars-sdl-0.9.2e.ebuild:
+ initial commit; ebuild based on the one submitted by Andreas Scholta via bug
+ #40738
+
diff --git a/games-simulation/pmars-sdl/Manifest b/games-simulation/pmars-sdl/Manifest
new file mode 100644
index 000000000000..45b129ea9204
--- /dev/null
+++ b/games-simulation/pmars-sdl/Manifest
@@ -0,0 +1,2 @@
+MD5 0e2b53226af252ab094456232de6ac3a pmars-sdl-0.9.2e.ebuild 1867
+MD5 d07727e8550216e842bfcfed75aece5f files/digest-pmars-sdl-0.9.2e 65
diff --git a/games-simulation/pmars-sdl/files/digest-pmars-sdl-0.9.2e b/games-simulation/pmars-sdl/files/digest-pmars-sdl-0.9.2e
new file mode 100644
index 000000000000..7644746a04d8
--- /dev/null
+++ b/games-simulation/pmars-sdl/files/digest-pmars-sdl-0.9.2e
@@ -0,0 +1 @@
+MD5 4733185c5eb6a4554a54d91331e6501d pmars-0.9.2-5.tar.gz 200966
diff --git a/games-simulation/pmars-sdl/metadata.xml b/games-simulation/pmars-sdl/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/pmars-sdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
new file mode 100644
index 000000000000..adbd6b65fecb
--- /dev/null
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild,v 1.1 2004/03/30 11:35:24 mr_bones_ Exp $
+
+inherit games
+
+MY_PN="${PN/-sdl/}"
+MY_PV="${PV/e/-5}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Portable redcode simulator's sdl port for core war"
+HOMEPAGE="http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl"
+SRC_URI="http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="sdl X svga"
+
+DEPEND="virtual/glibc
+ || (
+ sdl? ( virtual/x11 media-libs/libsdl )
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ ( sys-libs/ncurses sys-libs/libtermcap-compat )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ CFLAGS="${CFLAGS} -DEXT94 -DPERMUTATE"
+ LFLAGS="-x"
+
+ if use sdl ; then
+ CFLAGS="${CFLAGS} -DSDLGRAPHX `sdl-config --cflags`"
+ LIB=`sdl-config --libs`
+ elif use X ; then
+ CFLAGS="${CFLAGS} -DXWINGRAPHX"
+ LIB="-L/usr/X11R6/lib -lX11"
+ elif use svga ; then
+ CFLAGS="${CFLAGS} -DGRAPHX"
+ LIB="-lvgagl -lvga"
+ else
+ CFLAGS="${CFLAGS} -DCURSESGRAPHX"
+ LIB="-lcurses -ltermcap"
+ fi
+
+ cd src
+
+ SRC="asm.c
+ cdb.c
+ clparse.c
+ disasm.c
+ eval.c
+ global.c
+ pmars.c
+ sim.c
+ pos.c
+ str_eng.c
+ token.c"
+
+ for x in ${SRC}; do
+ einfo "compiling ${x}"
+ ${CC} ${CFLAGS} ${x} -c || die
+ done
+
+ echo
+ einfo "linking with LIB: ${LIB}"
+ ${CC} *.o ${LIB} -o ${MY_PN} || die
+}
+
+src_install() {
+ dogamesbin src/${MY_PN}
+ doman doc/${MY_PN}.6
+
+ dodoc AUTHORS CONTRIB ChangeLog README doc/redcode.ref
+
+ insinto "${GAMES_DATADIR}/${MY_PN}/warriors"
+ doins warriors/*
+
+ insinto "${GAMES_DATADIR}/${MY_PN}/macros"
+ doins config/*.mac
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ ewarn "There are some macros in ${GAMES_DATADIR}/${MY_PN}/macros"
+ ewarn "which you should make accessible to pmars by typing"
+ ewarn "export PMARSHOME=${GAMES_DATADIR}/${MY_PN}/macros\n"
+}