summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-09 20:56:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-09 20:56:45 +0000
commit82d818e06935119aede691eb7888c418713a485a (patch)
tree93b47e2ffb2472ade4e2c02237eaee2153b98da7 /games-simulation
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-82d818e06935119aede691eb7888c418713a485a.tar.gz
gentoo-2-82d818e06935119aede691eb7888c418713a485a.tar.bz2
gentoo-2-82d818e06935119aede691eb7888c418713a485a.zip
old
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.5.3_rc39
-rw-r--r--games-simulation/openttd/openttd-0.5.3_rc3.ebuild197
2 files changed, 0 insertions, 206 deletions
diff --git a/games-simulation/openttd/files/digest-openttd-0.5.3_rc3 b/games-simulation/openttd/files/digest-openttd-0.5.3_rc3
deleted file mode 100644
index 278759546b7b..000000000000
--- a/games-simulation/openttd/files/digest-openttd-0.5.3_rc3
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 34e8cb13ce1d4e6b5b24887c628c1ac8 openttd-0.4.8-scenarios.tar.bz2 5000799
-RMD160 a6c2fa9f81e4e4628adb9c3932dec46ab4789777 openttd-0.4.8-scenarios.tar.bz2 5000799
-SHA256 61788035bd78a3c0e393d5992432c37e0b6036d19a960543f26d43a46e39e6ca openttd-0.4.8-scenarios.tar.bz2 5000799
-MD5 37892f1fdded957f956766642a9e877d openttd-0.5.0-scenarios.tar.bz2 917117
-RMD160 f6ea4a4004bb0c90de9283a92b14da4bd99bc33c openttd-0.5.0-scenarios.tar.bz2 917117
-SHA256 c89e652aca1a9ad9f0f4936dd99cd8a9c96f4c53450990ff87d87483f8e74a31 openttd-0.5.0-scenarios.tar.bz2 917117
-MD5 51dcff96b756ba6ddfe7f43bd606ac19 openttd-0.5.3-RC3-source.tar.bz2 3023613
-RMD160 e735514319e3e62f2c28541917ebdcba2bd0cf3f openttd-0.5.3-RC3-source.tar.bz2 3023613
-SHA256 a6f07c8352c4df2cb2eb420141a94f8f96db746a497e378867b93b19aa4f543c openttd-0.5.3-RC3-source.tar.bz2 3023613
diff --git a/games-simulation/openttd/openttd-0.5.3_rc3.ebuild b/games-simulation/openttd/openttd-0.5.3_rc3.ebuild
deleted file mode 100644
index 4e587a0fe1f9..000000000000
--- a/games-simulation/openttd/openttd-0.5.3_rc3.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.5.3_rc3.ebuild,v 1.2 2007/09/03 02:32:56 mr_bones_ Exp $
-
-inherit eutils games
-
-MY_P=${P/_rc/-RC}
-
-SCENARIOS_048="${PN}-0.4.8-scenarios.tar.bz2"
-SCENARIOS_050="${PN}-0.5.0-scenarios.tar.bz2"
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.com/"
-SB="mirror://sourceforge/openttd"
-SRC_URI="${SB}/${MY_P}-source.tar.bz2
- scenarios? ( ${SB}/${SCENARIOS_048}
- ${SB}/${SCENARIOS_050} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa debug dedicated iconv png scenarios static timidity zlib"
-
-DEPEND="!dedicated? ( media-libs/libsdl
- media-libs/fontconfig
- )
- iconv? ( virtual/libiconv )
- png? ( media-libs/libpng )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}
- !dedicated? (
- timidity? ( media-sound/timidity++ )
- !timidity? ( alsa? ( media-sound/alsa-utils ) )
- )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if ! use dedicated && ! built_with_use media-libs/libsdl X ; then
- die "Please emerge media-libs/libsdl with USE=X"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-source.tar.bz2
- if use scenarios ; then
- cd ${S}/scenario/
- unpack ${SCENARIOS_048}
- unpack ${SCENARIOS_050}
- fi
- cd ${S}
- # Don't pre-strip binaries (bug #137822)
- sed -i -e '/+= -s$/s/-s//' Makefile || die "sed failed"
- # Don't install into prefixed DATA_DIR
- sed -i -e \
- 's#DATA_DIR_PREFIXED:=$(PREFIX)/$(DATA_DIR)#DATA_DIR_PREFIXED:=$(DATA_DIR)#' \
- Makefile || die "sed failed"
-}
-
-src_compile() {
- local myopts=""
- use debug && myopts="${myopts} --debug"
- use static && myopts="${myopts} --with-static"
- use dedicated && myopts="${myopts} --dedicated --without-sdl"
- use iconv && myopts="${myopts} --with-iconv"
- use png && myopts="${myopts} --with-png"
- use zlib && myopts="${myopts} --with-zlib"
- if ! use dedicated; then
- myopts="${myopts} --with-sdl --with-freetype --with-fontconfig"
- if ! use timidity; then
- #use alsa && myopts="${myopts} --with-midi=/usr/bin/aplaymidi"
- einfo "This RC of openttd does not support setting the midi-player."
- fi
- fi
- ./configure --os=UNIX \
- --with-network \
- ${myopts} \
- || die "configure failed"
-
- emake \
- MANUAL_CONFIG=1 \
- INSTALL=1 \
- USE_HOMEDIR=1 \
- DEST_DIR=${D} \
- PERSONAL_DIR=.openttd \
- PREFIX=${GAMES_PREFIX} \
- DATA_DIR=${GAMES_DATADIR}/${PN} \
- CUSTOM_LANG_DIR=${GAMES_DATADIR}/${PN}/lang \
- || die "emake failed"
-}
-
-src_install() {
- dogamesbin openttd || die "dogamesbin failed"
-
- insinto "${GAMES_DATADIR}/${PN}/data"
- doins data/* || die "doins failed (data)"
-
- insinto "${GAMES_DATADIR}/${PN}/lang"
- doins lang/*.lng || die "doins failed (lang)"
-
- if use scenarios ; then
- insinto "${GAMES_DATADIR}/${PN}/scenario"
- doins scenario/*.scn || die "doins failed (scenario)"
- doins scenario/*/*.scn || die "doins failed (scenario)"
- fi
-
- insinto "${GAMES_DATADIR}/${PN}/scripts"
- doins scripts/*.example || die "doins failed (scripts)"
-
- for i in {16,32,48,64,128}; do
- insinto /usr/share/icons/hicolor/${i}x${i}/apps
- newins media/openttd.${i}.png openttd.png
- done
-
- if ! use dedicated ; then
- if use timidity || use alsa ; then
- make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
- else
- make_desktop_entry openttd "OpenTTD" openttd
- fi
- else
- newinitd "${FILESDIR}"/openttd.initd openttd
- fi
-
- dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt \
- docs/multiplayer.txt
- dohtml -a html,gif,png,svg docs/*
- newdoc scripts/readme.txt readme_scripts.txt
- doman docs/openttd.6
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- echo
- einfo "In order to play, you must copy the following 6 files from "
- einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
- echo
- einfo "From the WINDOWS version you need: "
- einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- einfo "OR from the DOS version you need: "
- einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- echo
- einfo "File names are case sensitive so make sure they are "
- einfo "correct for whichever version you have."
- echo
-
- if ! use scenarios ; then
- einfo "Scenarios are now included in a seperate package. To "
- einfo "install them as well please remerge with the "
- einfo "\"scenarios\" USE flag."
- echo
- else
- einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
- einfo "you will have to symlink them to ~/.openttd/scenario in order"
- einfo "to use them."
- einfo "Example:"
- einfo " mkdir -p ~/.openttd/scenario"
- einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
- echo
- fi
-
- if use dedicated ; then
- einfo "You have chosen the dedicated USE flag which builds a "
- einfo "version of OpenTTD to be used as a game server which "
- einfo "does not require SDL. You will not be able to play the "
- einfo "game, but if you don't pass this flag you can still use "
- einfo "it as a server in the same way, but SDL will be required."
- echo
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when run, including any running client sessions!"
- echo
- else
- if use timidity || use alsa ; then
- einfo "If you want music, you must copy the gm/ directory"
- einfo "to ${GAMES_DATADIR}/${PN}/"
- einfo "You can enable MIDI by running:"
- einfo " openttd -m extmidi"
- echo
- if use timidity ; then
- einfo "You also need soundfonts for timidity, if you don't"
- einfo "know what that is, do:"
- echo
- einfo "emerge media-sound/timidity-eawpatches"
- else
- einfo "You have emerged with 'aplaymidi' for playing MIDI."
- einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
- einfo "Available ports can be listed by using 'aplaymidi -l'."
- fi
- else
- einfo "timidity and/or alsa not in USE so music will not be played during the game."
- fi
- echo
- fi
-}