summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 22:24:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 22:24:06 +0000
commitab40e70d8e381745574fe7accd3236a635cc763d (patch)
treef1160b97253feed3b574624d15550f06daa55263 /games-sports/foobillard/foobillard-3.0a.ebuild
parentAdded ~hppa, bug #148659 (diff)
downloadgentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.tar.gz
gentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.tar.bz2
gentoo-2-ab40e70d8e381745574fe7accd3236a635cc763d.zip
fixup nvidia detection and add fbsd support - patch from Diego Pettenò (bug #149718)
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-sports/foobillard/foobillard-3.0a.ebuild')
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index 69b160722da6..45938ac3e1ab 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.7 2006/01/29 08:04:42 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.8 2006/10/01 22:24:06 mr_bones_ Exp $
-inherit eutils games
+inherit eutils autotools games
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sunsite.dk/"
@@ -13,10 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="sdl"
-DEPEND="|| ( ( x11-libs/libXaw
- x11-libs/libXi )
- virtual/x11
- )
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXi
virtual/opengl
>=media-libs/freetype-2.0.9
>=media-libs/libpng-1.2.1
@@ -26,18 +24,24 @@ DEPEND="|| ( ( x11-libs/libXaw
virtual/glu
virtual/glut )
)"
+DEPEND="${RDEPEND}
+ app-admin/eselect"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-no_nvidia.patch
+ epatch \
+ "${FILESDIR}"/${P}-no_nvidia.patch \
+ "${FILESDIR}"/${P}-fbsd.patch
+
+ eautoreconf
}
src_compile() {
- local myconf=""
- [ "$(ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5)" == "nvidia" ] \
- && myconf="--enable-nvidia=yes" \
- || myconf="--enable-nvidia=no"
+ local myconf
+ [[ "$(eselect opengl show)" == 'nvidia' ]] \
+ && myconf='--enable-nvidia=yes' \
+ || myconf='--enable-nvidia=no'
egamesconf \
--enable-sound \
@@ -49,13 +53,10 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README README.FONTS
doman foobillard.6
-
- insinto /usr/share/pixmaps
- newins data/full_symbol.png foobillard.png
- make_desktop_entry foobillard Foobillard foobillard.png
-
+ newicon data/full_symbol.png foobillard.png
+ make_desktop_entry foobillard Foobillard
prepgamesdirs
}