summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-01 02:14:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-01 02:14:27 +0000
commit3a3721c51a4bc574ee7b145a18f01d5378c03156 (patch)
tree4dccdea38d59293fe85b172a3c1361b4f74457c7 /games-sports
parentold (diff)
downloadgentoo-2-3a3721c51a4bc574ee7b145a18f01d5378c03156.tar.gz
gentoo-2-3a3721c51a4bc574ee7b145a18f01d5378c03156.tar.bz2
gentoo-2-3a3721c51a4bc574ee7b145a18f01d5378c03156.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/toycars/ChangeLog8
-rw-r--r--games-sports/toycars/toycars-0.3.10.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/games-sports/toycars/ChangeLog b/games-sports/toycars/ChangeLog
index d143d652c2c1..b96f7d76afa2 100644
--- a/games-sports/toycars/ChangeLog
+++ b/games-sports/toycars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/toycars
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.12 2009/06/03 20:05:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.13 2009/07/01 02:14:27 mr_bones_ Exp $
+
+*toycars-0.3.10 (01 Jul 2009)
+
+ 01 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +toycars-0.3.10.ebuild:
+ version bump
*toycars-0.3.9 (03 Jun 2009)
diff --git a/games-sports/toycars/toycars-0.3.10.ebuild b/games-sports/toycars/toycars-0.3.10.ebuild
new file mode 100644
index 000000000000..e8b4000ff57c
--- /dev/null
+++ b/games-sports/toycars/toycars-0.3.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.10.ebuild,v 1.1 2009/07/01 02:14:27 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="a physics based 2-D racer inspired by Micro Machines"
+HOMEPAGE="http://sourceforge.net/projects/toycars"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ >=x11-libs/fltk-1.1.9:1.1
+ >=media-libs/fmod-4.25.07-r1:1
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-ldflags -L/opt/fmodex/api/lib
+ egamesconf
+}
+
+src_install() {
+ local d,f
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon toycars/celica-render.png ${PN}.png
+ make_desktop_entry ${PN} "Toy Cars"
+ dodoc AUTHORS
+
+ for d in toycars toycars_track_editor toycars_vehicle_editor
+ do
+ for f in ChangeLog README TODO
+ do
+ if [[ -s $d/$f ]] ; then
+ newdoc $d/$f $d.$f
+ fi
+ done
+ done
+ prepgamesdirs
+}