summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
commit0c0186e57f9c188f3c71c04a35825c8e134cf141 (patch)
tree764612f703bdba5335d790064606b1f53a330c24 /games-strategy/castle-combat/castle-combat-0.7.4.ebuild
parentminor version update. resolves bug 27641 (diff)
downloadgentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.gz
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.tar.bz2
gentoo-2-0c0186e57f9c188f3c71c04a35825c8e134cf141.zip
mmm strategy games
Diffstat (limited to 'games-strategy/castle-combat/castle-combat-0.7.4.ebuild')
-rw-r--r--games-strategy/castle-combat/castle-combat-0.7.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-strategy/castle-combat/castle-combat-0.7.4.ebuild b/games-strategy/castle-combat/castle-combat-0.7.4.ebuild
new file mode 100644
index 000000000000..0ac1a32ae254
--- /dev/null
+++ b/games-strategy/castle-combat/castle-combat-0.7.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/castle-combat/castle-combat-0.7.4.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A clone of the old arcade game Rampart"
+HOMEPAGE="http://www.linux-games.com/castle-combat/"
+SRC_URI="http://user.cs.tu-berlin.de/~karlb/castle-combat/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+RDEPEND="virtual/glibc
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # dist file seems to include a copy of SDL_net. Take it out so we link
+ # against the system copy instead.
+ sed -i -e "s/SDL_net//" src/Makefile.in || die "sed src/Makefile.in failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
+ prepgamesdirs
+}