summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-21 08:21:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-21 08:21:53 +0000
commitd8b1faa585f0f4c085477f18616202750a8c960e (patch)
tree3f84c1d3d1b370ab031f459602b956702c53c623 /games-strategy/freecraft
parentFix libxml DEP. (diff)
downloadgentoo-2-d8b1faa585f0f4c085477f18616202750a8c960e.tar.gz
gentoo-2-d8b1faa585f0f4c085477f18616202750a8c960e.tar.bz2
gentoo-2-d8b1faa585f0f4c085477f18616202750a8c960e.zip
add patch to work with newer GNU make from Jeremy Wilkins via bug #158705
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-strategy/freecraft')
-rw-r--r--games-strategy/freecraft/ChangeLog6
-rw-r--r--games-strategy/freecraft/files/freecraft-1.18-Makefile.patch15
-rw-r--r--games-strategy/freecraft/freecraft-1.18-r3.ebuild5
3 files changed, 23 insertions, 3 deletions
diff --git a/games-strategy/freecraft/ChangeLog b/games-strategy/freecraft/ChangeLog
index adb3089c9b10..6fb13503a072 100644
--- a/games-strategy/freecraft/ChangeLog
+++ b/games-strategy/freecraft/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/freecraft
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecraft/ChangeLog,v 1.13 2006/10/04 22:40:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecraft/ChangeLog,v 1.14 2006/12/21 08:21:53 mr_bones_ Exp $
+
+ 21 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/freecraft-1.18-Makefile.patch, freecraft-1.18-r3.ebuild:
+ add patch to work with newer GNU make from Jeremy Wilkins via bug #158705
04 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
freecraft-1.18-r3.ebuild:
diff --git a/games-strategy/freecraft/files/freecraft-1.18-Makefile.patch b/games-strategy/freecraft/files/freecraft-1.18-Makefile.patch
new file mode 100644
index 000000000000..62b634c5c06b
--- /dev/null
+++ b/games-strategy/freecraft/files/freecraft-1.18-Makefile.patch
@@ -0,0 +1,15 @@
+--- Makefile.orig 2003-03-11 22:03:34.000000000 -0600
++++ Makefile 2006-12-21 00:00:54.000000000 -0600
+@@ -172,9 +172,9 @@
+ depend:
+ @echo -n >.depend
+ @echo
+- @for i in $(SRC) ; do\
+- echo -e "\rMaking dependencies for $$i";\
+- echo -n `dirname $$i`/$(OBJDIR)/ >> .depend;\
++ @for i in $(SRC) ; do \
++ echo -e "\rMaking dependencies for $$i"; \
++ echo -n `dirname $$i`/$(OBJDIR)/ >> .depend; \
+ $(CC) -MM $(IFLAGS) $(DFLAGS) $(CFLAGS) $$i >>.depend ; done
+ @echo
+
diff --git a/games-strategy/freecraft/freecraft-1.18-r3.ebuild b/games-strategy/freecraft/freecraft-1.18-r3.ebuild
index 41cedfeb4ff3..fd2fd9080214 100644
--- a/games-strategy/freecraft/freecraft-1.18-r3.ebuild
+++ b/games-strategy/freecraft/freecraft-1.18-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecraft/freecraft-1.18-r3.ebuild,v 1.12 2006/10/04 22:40:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecraft/freecraft-1.18-r3.ebuild,v 1.13 2006/12/21 08:21:53 mr_bones_ Exp $
inherit eutils games
@@ -33,7 +33,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PV}-setup.patch" \
- "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-Makefile.patch
env GENTOO_CFLAGS="${CFLAGS}" ./setup || die
}